Dystrybucje Linux > Arch

Problem z aktualizacją lib32-libpcap ROZWIĄZANY

(1/11) > >>

Piejanto:
Dziś siadłem do mojego Asusa z Archem XFCE i wydałem polecenia:
pak -m
a następnie
pak -Syu
Rozpoczęła się aktualizacja i znów zawód. Otrzymałem następujący komunikat:
*****
Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja libpcap (1.10.1-1) uszkodzi zależności 'libpcap=1.10.0' wymagane przez lib32-libpcap
*****
Co powinienem zrobić? - Domyślam się, że powinienem coś ręcznie wyrzucić. Tylko co?


pavbaranov:
Raz jeszcze puścić aktualizację, a jeśli problem się powtórzy - zmienić repozytoria, bo są stare (mimo pak -m). W oficjalnym repo jest właściwa paczka:
--- Kod ---https://archlinux.org/packages/multilib/x86_64/lib32-libpcap/
--- Koniec kodu ---

robson75:
Tu pytanie, czy na pewno potrzebujesz bibliotek lib32?
Bo jeżeli nie, to niepotrzebnie masz odkomentowane repo multilib.

pavbaranov:
Robert - samo odkomentowanie niczego nie powoduje. Dopiero jak jakiś program potrzebuje lib32-* to coś ciągnie. IMO - jeśli nie ma się 100% pewności, że żaden program, żaden sprzęt nie wymaga lib32, to lepiej to mieć odkomentowane. Jedyny niechciany efekt, to nieco wolniejsza synchronizacja lokalnej z odległą bazy oprogramowania.
Nadto, jeśli Janek nie potrzebuje lib32-*, to samo odkomentowanie repozytorium nie rozwiąże problemu - należałoby również usunąć paczkę lib32-libpcap (ta jest zależnością wine, zatem jeśli Janek go używa, to rozwiązanie jest bez sensu).

robson75:
Paweł, miałem na myśli że zakomentowanie repo multilib, wiąże się z tym ażeby pousuwać wszystkie paczki lib32.
Znając Janka to raczej nie korzysta z wine  :)

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej