Dystrybucje Linux > Arch

Porządek z partycjami.

(1/3) > >>

kotecek:
Witam. Mam nadzieje ze nikt sie nie obrazi ze takze pomocy poszukam tutaj :)
Sprawa wyglada tak:

--- Kod ---https://forum.manjaro.pl/t/porzadek-z-partycjami/1932/27
--- Koniec kodu ---

pavbaranov:
Krótko:
1. Zaopatrz się w liveiso Manjaro i upewnij, że znajduje się na nim manjaro-chroot, albo podobnie (nie mam Manjaro) - lub jeśli jest tam jakieś narzędzie do ; jeśli nie ma - nie problem, później dojdziemy.
2. Wywal sda3.
3. Zrestartuj system.
4. Jeśli wszystko pójdzie dobrze - trzeba będzie jeszcze zrobić porządek z GRUB (prawdopodobnie); jeśli nie - pkt 5 i dalsze.
5. Jeśli system nie wystartuje - wystartuj go z liveiso i użyj albo narzędzia do przywracania GRUB (jeśli jest), albo chroota i przeinstaluj wówczas GRUB.

ciubaka:
Straszne skomplikowane metody są opisywane na forum Manjaro.
Ja się nie znam, ale bym to robił "na chamca".
1. Bekap danych wrażliwych.
2. Przygotowanie Boot Repair Dysk live na penie, właściwego dla posiadanego Manjaro (32 lub 64 bity, jak nie wiesz który to oba na wszelki wypadek).
3. Przygotowanie Gparted live na penie.
4. Odpalamy Gparted live, usuwamy sda3, rozszerzamy sda2 (bo zdaje się o to chodziło).
5. Sprawdzamy czy Manjaro startuje, jeżeli nie to odpalamy BRD live i naprawiamy rozruch.
6. Sprawdzamy czy Manjaro startuje (na 90% tak).
7. Jak nie to instalujemy jakiegoś (dowolnego, może być nawet i Manjaro jak ktoś lubi) linuxa od nowa i wgrywamy dane wrażliwe z powrotem.
Moim zdaniem proces zakończy się na punkcie 5 lub 6.
Tak to bywało u mnie dotychczas.
Ale ja się nie znam.
Ps. Ja też dogrywałem kiedyś Manjaro do innych systemów i u mnie też to się z innymi systemami pogryzło. BRD sprawiał, że działały albo inne systemy, albo Manjaro. Na szczęście wywaliło się niedługo później przy aktualizacji i problem znikł. Razem z Manjaro. Inne systemy zostały.

kotecek:
ok ogarnalem :)
robilem wg tego:

--- Kod ---https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader
--- Koniec kodu ---

tylko dla efi system.

Co prawda odpalil sie czarny ekranik bo ten hp 8470p, ma jakies dziwne menu bootowania i jak jest os prober to sie tak wlasnie stalo.
Ale wybralem botowanie z efi i wskazalem grub (nie wiem czy to zadzialalo, ale uruchomil sie)
Pozniej sprawdzilem jeszcze raz ale wybralem opcje zamiast os prober manjaro (bylo tez ubuntu, nie wiem dlaczego, skoro partycja poszla w piach sda3) i tez ruszylo.

Takze wszystko dziala i dziekuje Wam pieknie :)
A takie pytanko:
Czy jak zrobilbym jak dla bios system by zadzialalo z tej wiki manjaro?

pavbaranov:
Sprawdź sobie co co masz w /boot/efi oraz jakie są wpisy w GRUB (rozumiem, że jakieś "update-grub" zrobiłeś).

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej