Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Problem z apt  (Przeczytany 2751 razy)

Offline Kancermeister

  • Newbie
  • *
  • Wiadomości: 4
  • Reputacja: 0
Odp: Problem z apt
« Odpowiedź #15 dnia: Czerwiec 14, 2021, 06:56:46 pm »
Miałem podobny problem z przerwaną instalacją pakietu openoffice.org-debian-menus. Każda próba działania z apt kończyła się komunikatem
Cytuj
Pakiet openoffice.org-debian-menus ma zostać ponownie zainstalowany, ale nie można znaleźć jego archiwum

W końcu, po przewertowaniu manuala dpkg poradziłem sobie w ten sposób:

Polecenie sudo dpkg -C wylistowało problemy:
Niżej wymienione pakiety zostały częściowo zainstalowane, gdyż wystąpiły
problemy podczas ich instalowania. Proces ten prawdopodobnie może zostać
powtórzony; pakiety mogą też być usunięte poprzez wywołanie dpkg --remove
lub użycie dselect.
 openoffice.org-debian-menus (brak dostępnego opisu)

Następujące pakiety nie posiadają pliku kontrolnego list
w bazie danych i muszą zostać zainstalowane ponownie:
 openoffice.org-debian-menus (brak dostępnego opisu)

Następujące pakiety nie posiadają pliku kontrolnego md5sums
w bazie danych i muszą zostać zainstalowane ponownie:
 openoffice.org-debian-menus (brak dostępnego opisu)

Następnie skopiowałem nazwę pakietu, czyli openoffice.org-debian-menus do schowka i wprowadziłem polecenie sudo dpkg --remove openoffice.org-debian-menus, co dało następujący wynik:
(Odczytywanie bazy danych ... 451235 plików i katalogów obecnie zainstalowanych.)
Usuwanie pakietu openoffice.org-debian-menus (3.3-9556) ...

Ponowne wprowadzenie sudo dpkg -C dało pusty wynik.

Wprowadzenie sudo apt autoremove dało:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
(czyli pocieszająca norma)

Z kolei bez problemów uruchomiłem Synaptic i usunąłem całkowicie openoffice.

System pracuje bez problemów.

Może to komuś pomoże.