Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Polskie znaki łóśćźż nadal problemem po instalacji w 2021 r.?  (Przeczytany 216 razy)

Offline Wirtualny

  • Newbie
  • *
  • Wiadomości: 1
  • Reputacja: 0
Witam,

Zainstalowałem MX Linux 19.4 wybierając polską lokalizację. Mam polski interface, ale jak widać programiści linuksowi nie uznali, że powinny być dostępne polskie znaki, bo po co komu jakieś: łąśćżź.

Uznałem, że to jakiś mały problem i znalazłem w necie poradę, żeby w konsoli wpisać:

setxkbmap pl

Problem w tym, że to działa do następnego restartu. Czy to jest ergonomiczne? Dlaczego programiści uznali, że użytkownik, który wybrał polską lokalizację nie chce polskich znaków łóżźćś? Dlaczego programiści linuksowi uznają, że skoro użytkownik już sobie ustawił polskie znaki, to po restarcie życzy sobie ich znowu nie mieć.

Wracam na Linuksa po 15 latach. Wtedy sformatowałem Ubuntu właśnie przez to, że zamiast pracować, musiałem się zabawiać w "pana dłubaka". Po 15 latach widzę, że nadal jest to samo... To niesamowite. System nawet stabilny, fajny, ale irytuje nowego użytkownika, chyba w najgłupszy możliwy sposób.
« Ostatnia zmiana: Czerwiec 26, 2021, 06:26:55 pm wysłana przez Wirtualny »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1655
  • Reputacja: 10
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Polskie znaki łóśćźż nadal problemem po instalacji w 2021 r.?
« Odpowiedź #1 dnia: Czerwiec 26, 2021, 07:07:36 pm »
Jak się domyślam, to masz DE Xfce4. Czy próbowałeś zmienić język w klawiatura>układ na polski ?

Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline Fibogacci

  • Full Member
  • ***
  • Wiadomości: 218
  • Reputacja: 9
Odp: Polskie znaki łóśćźż nadal problemem po instalacji w 2021 r.?
« Odpowiedź #2 dnia: Czerwiec 26, 2021, 08:43:11 pm »
Witam,

Zainstalowałem MX Linux 19.4 wybierając polską lokalizację. Mam polski interface, ale jak widać programiści linuksowi nie uznali, że powinny być dostępne polskie znaki, bo po co komu jakieś: łąśćżź.

Uznałem, że to jakiś mały problem i znalazłem w necie poradę, żeby w konsoli wpisać:

setxkbmap pl

Problem w tym, że to działa do następnego restartu. Czy to jest ergonomiczne? Dlaczego programiści uznali, że użytkownik, który wybrał polską lokalizację nie chce polskich znaków łóżźćś? Dlaczego programiści linuksowi uznają, że skoro użytkownik już sobie ustawił polskie znaki, to po restarcie życzy sobie ich znowu nie mieć.

Wracam na Linuksa po 15 latach. Wtedy sformatowałem Ubuntu właśnie przez to, że zamiast pracować, musiałem się zabawiać w "pana dłubaka". Po 15 latach widzę, że nadal jest to samo... To niesamowite. System nawet stabilny, fajny, ale irytuje nowego użytkownika, chyba w najgłupszy możliwy sposób.

Nie wiem jak instalowałeś i co robiłeś w międzyczasie, ale w takich przypadkach z większym prawdopodobieństwem przyczyną problemu jest użytkownik, a nie programiści.

Aby rozwiązać skutecznie problem w menu startowym znajdź Klawiatura, wybierze kartę Układ i zobacz, czy jest Polski. Jeśli nie ma, dodaj.


 


Te informacje (jak dostosować klawiaturę i język) znajdziesz też w Podręczniku użytkownika MX Linux na stronie 105 w części 3.7 Lokalizacja. Podręcznik znajdziesz na pulpicie MX Linux (Manual) - gdy system jest uruchomiony po polsku, podręcznik jest po polsku.
« Ostatnia zmiana: Czerwiec 26, 2021, 08:46:37 pm wysłana przez Fibogacci »