Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Uszkodzone pakiety, problem z instalacją libreoffice  (Przeczytany 530 razy)

Offline CoyaDeBrojara

  • Newbie
  • *
  • Wiadomości: 43
  • Reputacja: 6
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #15 dnia: Maj 04, 2021, 08:49:30 pm »
Hej. Jak rozumiem podałeś wpisy z pliku
Cytuj
/etc/apt/sources.list
Czy możesz podać wpisy umieszczone w katalogu
Cytuj
/etc/apt/sources.list.d/
z plików z rozszerzeniem .list

Z podanych przez Ciebie informacji wynika że nie powinieneś mieć problemów, jednakże twój pierwszy post sugeruje że gdzieś chowają się dodatkowe wpisy.

Taka sytuacja, jaką opisałeś, zdaża się gdy nie zgadzają się wersje pakietów. Program wymaga wersji innej niż jest dostępna w systemie. Często się zdarza gdy masz pomieszane repozytoria, na przykład wersja stabilna z testową lub sid.
Taki przykład:
Cytuj
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 firefox : Wymaga: libnss3 (>= 2:3.63~) ale 2:3.61-1 ma zostać zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Offline paraksiarz

  • Newbie
  • *
  • Wiadomości: 14
  • Reputacja: 0
  • antiX 19,3 IceWM
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #16 dnia: Maj 04, 2021, 11:06:59 pm »
tu nie ma plku:
Cytuj
/etc/apt/sources.list
podałem wpisy ze wszystkich plików .list znajdujących się w katalogu:
Cytuj
/etc/apt/sources.list.d/

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3050
  • Reputacja: 48
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #17 dnia: Maj 04, 2021, 11:54:13 pm »
Być może jest jakiś konflikt z backports, a "stable". Pomijam już kompletnie niewspieraną staroć 4.x, ale to jest Debian - oni wiedzą lepiej i będą jeszcze pitolić, że to dla Twojego dobra :D Możesz spróbować jeszcze stąd: https://www.libreoffice.org/download/download/. Upewnij się, że żadnej paczki z libreoffice w nazwie nie masz w systemie.

Offline paraksiarz

  • Newbie
  • *
  • Wiadomości: 14
  • Reputacja: 0
  • antiX 19,3 IceWM
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #18 dnia: Maj 05, 2021, 03:47:35 pm »
Nie rozumiem co to znaczy:
Cytuj
konflikt z backports, a "stable". Pomijam już kompletnie niewspieraną staroć 4.x
Chciałbym zainstalować z repozytoriów oficjalnych, bo czytałem, że to najlepsze wersję są dla systemu, a ręczne instalowanie może zrobić problem. Więc jeszcze zaczekam na forum na jakieś pomysły. Ale dziękuję.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3050
  • Reputacja: 48
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #19 dnia: Maj 05, 2021, 05:38:26 pm »
Ta paczka od libreoffice.org nie zrobi Ci żadnego problemu. Kiedy miałem Debiana/Kubuntu była to często jedyna możliwość, by mieć tam nowe LO, które bywało sporo polepszone.

W backports jest nowsza wersja niż w stable. Winna się przy instalacji być stąd pobierana, ale... bóg jeden raczy wiedzieć.
Pomysły? Sprawdzić czy coś z LO jest jeszcze do usunięcia. Chyba winno to wyglądać tak (zwróć uwagę, że od blisko 10 lat nie mam już deb):
# apt-get remove libreoffice*-*Spróbować instalacji.
# apt-get update && apt-get install libreoffice(Uwaga: nie mam 100% pewności, czy paczka się nazywa libreoffice - byłaby to jakaś meta-paczka wówczas; jeśli nie tak, to libreoffice-gtk lub libreoffice-gtk3 - jeśli używasz jakiegoś DE na GTK - pierwsze dla wersji 2, drugie dla 3).
Opcja inna - ściągnąć z repozytoriów wszystkie interesujące Cię paczki na dysk i zainstalować je (zbiorczo) przez dpkg.
# dpkg -i *.debwydane z katalogu, gdzie znajdują się pobrane paczki deb.

Offline CoyaDeBrojara

  • Newbie
  • *
  • Wiadomości: 43
  • Reputacja: 6
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #20 dnia: Maj 05, 2021, 07:37:56 pm »
Cytuj
Nie rozumiem co to znaczy:
konflikt z backports, a "stable". Pomijam już kompletnie niewspieraną staroć 4.x

Wersja Debiana zwana Buster, to wersja stabilna i takowych repozytoriów używasz, Buster - czyli na ten czas stable.
Backporty to repozytoria zawierające pakiety wersji rozwojowej - testowej (testing). Są one przepakietowane z wersji testing do wersji stable w sposób taki, by spełniały prawidłowo wszelkie zależności wersji stabilnej. Niestety to tylko teoria... Generalnie po kilku latach używania Debiana, zauważyłam że błędem jest mieszanie repozytoriów z różnych dystrybucji, to proszenie się o kłopoty. Nawet używanie backportów jest ryzykowne w dłuższej perspektywie. Debian to naprawdę fajny i bezawaryjny system, po warunkiem że się odrobinkę o niego dba.
Staroć 4.x dotyczy wersji kernela.

Więc może być jak mówisz. W wydaniu buster mamy wersje 1:6.1.5-3+deb10u7 a w backportach 1:7.0.4~rc2-1~bpo10+2.  Może odznacz backporty i zrób
sudo apt updatea następnie
sudo apt install libreoffice
przed instalacją proponuje usunąć katalog ustawień LibreOffice znajdujący się w ~/.config/libreoffice, tak na wszelki wypadek.

W razie czego pobierz LibreOffice z poniższego linku i zainstaluj jak pan Paweł radzi przez dpkg:
Cytuj
https://ftp.acc.umu.se/mirror/documentfoundation.org/libreoffice/stable/7.1.2/deb/x86_64/LibreOffice_7.1.2_Linux_x86-64_deb.tar.gz

Offline Piotr_1988

  • Full Member
  • ***
  • Wiadomości: 244
  • Reputacja: 10
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #21 dnia: Maj 09, 2021, 08:34:48 pm »
Chciałbym zainstalować z repozytoriów oficjalnych, bo czytałem, że to najlepsze wersję są dla systemu, a ręczne instalowanie może zrobić problem. Więc jeszcze zaczekam na forum na jakieś pomysły. Ale dziękuję.
Posunąłem Ci już dwa bezpieczne pomysły: flatpak i appimage Możesz bezpiecznie używać appimage do czasu aż rozwiążesz problem z repozytoriami (lub tym co u Ciebie nie działa).
« Ostatnia zmiana: Maj 09, 2021, 08:37:24 pm wysłana przez Piotr_1988 »
Fedora 34  |  Oracle Linux 8

Offline paraksiarz

  • Newbie
  • *
  • Wiadomości: 14
  • Reputacja: 0
  • antiX 19,3 IceWM
Odp: Uszkodzone pakiety, problem z instalacją libreoffice
« Odpowiedź #22 dnia: Maj 16, 2021, 02:44:00 pm »
Nie pomogło:
# apt-get remove libreoffice*-*
# apt-get update && apt-get install libreoffice

Też nie pomogło:
sudo apt update
sudo apt install libreoffice

Flatpak to jest jakieś rozwiązanie, ale to trochę ominięcie problemu. Z tego co czytałem flatpak ściąga też dodatkowo wszystkie biblioteki potrzebne do libreoffice, nawet te, które są już w systemie i  tworzy osobno takie prywatne środowisko dla programu, zajmie to więcej miejsca na dysku, a ja miejsce chcę oszczędzać.

Pomogła instalacja za pomocą dpkg, Zainstalowałem libreoffice z roku 2019, wersję 6.2.8.2 32bit, bo z tego co czytałem od wersji 6.3 wychodzi tylko wersja 64bit dla linux, a przypomnę, że system mam 32bit.

Brak możliwości instalacji z repozytoriów nadal zostaje dla mnie zagadką.

Dziękuję wszystkim za pomoc.