Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Aplikacje nie ładują się gdy jestem zalogowany na roota.

Zaczęty przez Wiktor, Marzec 03, 2021, 10:42:50 PM

Poprzedni wątek - Następny wątek

Wiktor

Ładują mi się tylko aplikacje systemowe np. firefox. Ale chrome mi się nie uruchamia. Gdy loguję się na inne konto nie mam tego problemu. Proszę o pomoc. Pozdrawiam.

pavbaranov

I jest wszystko w najlepszym porządku. Na root nie powinny Ci się w ogóle ładować jakiekolwiek aplikacje GUI. Kwestia bezpieczeństwa.

Wiktor

Da się to jakoś zmienić? Nie sądzę że chrome mógł by być zagrożeniem dla mojego pc.

robson75

Cytat: Wiktor w Marzec 03, 2021, 10:59:38 PM
Nie sądzę że chrome mógł by być zagrożeniem dla mojego pc.
Dla pc nie, ale dla systemu już tak. Pamiętam jak to było u mnie parę lat temu, po zainstalowaniu Kodi w ogóle nie chciał mi się uruchamiać, więc wpadłem na "genialny" pomysł aby go uruchomić przez terminal jako root, no i się uruchomił. Ale na drugi dzień gdy uruchomiłem przeglądarkę system mi się zawiesił, i konieczny był hard reset, i tak kilka razy dziennie. Chcąc nie chcąc musiałem stawiać system od nowa.

Tak więc trzeba uważać gdy się chce uruchamiać jakikolwiek program jako root.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

microsofter

Cytat: pavbaranov w Marzec 03, 2021, 10:55:14 PM
I jest wszystko w najlepszym porządku. Na root nie powinny Ci się w ogóle ładować jakiekolwiek aplikacje GUI. Kwestia bezpieczeństwa.
A ja myślałem, że to CLI jest zagrożeniem. Wiadomo, można palnąć rm albo chmod. Dlaczego akurat aplikacje GUI? masz na myśli potencjalne luki?
były: MS-DOS, MS Windows, Sun Solaris; jest: Oracle Solaris

Zobacz najnowsze wiadomości na forum