Dystrybucje Linux > openSUSE

openSuse Tumbleweed { nie uruchamia programów }

(1/2) > >>

wojtek001:
Witam szanowne grono użytkowników - na wstępie pozdrawiam ! - Mam problem z uruchamianiem programów , tj np gry potato guy , edydory tekstowe  ( kwrite , kate ) i jeszcze kilka innnych , robiłem update - nic to nie pomaga- jestem raczej początkującym użytkownikiem Linuxa ;-) może mi ktoś pomoże rozwiązać problem ?
edit : klikając na uruchomienie programu po prostu nic się nie dzieje

pavbaranov:
Skoro robiłeś jakąś aktualizację, masz zainstalowaną potato guy, to jakieś programy jednak działają. Skoro tak, to sprawdź, czy działa konsola, a w niej wpisz program, który się nie uruchamia (np. kwrite, czy kate) i to co się ukaże w konsoli wrzuć tu.
Czy dokonywałeś jakichś zmian w Plazma (chyba ten DE masz, skoro masz tam kate i kwrite), a jeśli tak to jakich?

wojtek001:

--- Kod: ---wojtek@localhost:~> kwrite
kwrite: symbol lookup error: /usr/lib64/libKF5XmlGui.so.5: undefined symbol: _ZN19KeySequenceRecorder16recordingChangedEv
wojtek@localhost:~> kate
kate: symbol lookup error: /usr/lib64/libKF5XmlGui.so.5: undefined symbol: _ZN19KeySequenceRecorder16recordingChangedEv
wojtek@localhost:~>
--- Koniec kodu ---

żadnych zmian nie wprowadzałem , jestem " początkującym użyszkodnikiem :/
edit: :/
Tak dzialaja programy takie jak pakiety office libre program ftp filezilla , gnome i przegladarki pewnie inne również

pavbaranov:
1. Z jakim środowiskiem masz system?
2. Czy system jest w całości zaktualizowany? (Masz system typu rolling release, w którym zwykle instalując jakąś paczkę dobrze jest to zrobić wraz z aktualizacją systemu; nie wiem akurat, czy Tumbleweed ma na sztywno wpisane wersje zależności, na których paczki są budowane, ale dokonanie aktualizacji przy instalacji paczek w rollingach nigdy nie przeszkadza).
3. Skąd pochodzą paczki, które nie chcą działać? (repozytorium, jakieś pakiety uniwersalne, inne)

wojtek001:
  Takie coś udało mi się wykombinować w termialu

--- Kod: ---OS: openSUSE 2020081

        Kernel: x86_64 Linux 5.8.0-1-default
        Uptime: 1d 11h 36m
   lKO.       Packages: 2485
      Shell: bash
    Resolution: 1920x1080
    DE: GNOME 3.36.4
   WM: Mutter
   WM Theme:
GTK Theme: Adwaita [GTK2/3]
   kKAVKKKKKKKKKKKK0x;,,......,;od
 lKP      Icon Theme: Adwaita
     Font: Cantarell 11
    Disk: 274G / 394G (71%)
    CPU: Intel Core i7-2630QM @ 8x 2.9GHz [57.0°C]
 GPU: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
     RAM: 5321MiB / 7854MiB
--- Koniec kodu ---
edit : paczki pochodza ze stron autora glownie rpm instaluje


edit2: jeszcze takie oś


--- Kod: ---[sudo] hasło użytkownika root:
Pobieranie metadanych repozytorium 'openSUSE:Tumbleweed' .................[błąd]
Repozytorium 'openSUSE:Tumbleweed' jest niepoprawne.
[https-download.opensuse.org-1d97804a|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Pod podanym adresem URL nie znaleziono prawidłowych metadanych
Historia:
 - [https-download.opensuse.org-1d97804a|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.

Proszę sprawdzić, czy zdefiniowane adresy URI dla tego repozytorium wskazują na poprawne repozytorium.
Ostrzeżenie: Pominięto repozytorium 'openSUSE:Tumbleweed' z powodu powyższego błędu.
Pobieranie metadanych repozytorium 'openSUSE:Tumbleweed' .................[błąd]
Repozytorium 'openSUSE:Tumbleweed' jest niepoprawne.
[https-download.opensuse.org-a3b22c15|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Pod podanym adresem URL nie znaleziono prawidłowych metadanych
Historia:
 - [https-download.opensuse.org-a3b22c15|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Repository type can't be determined.
--- Koniec kodu ---

edit3

przy aktualizacji wszystkich pakietow mam błąd którego również nie rozumiem


--- Kod: ---ruby2.7-2.7.2-2.2.x86_64 jest w konflikcie z namespace:otherproviders(ruby-default) dostarczonym przez ruby2.6-2.6.5-1.2.x86_64
libusbmuxd-2_0-6-2.0.2-1.2.x86_64 wymaga libplist-2.0.so.3()(64bit), lecz nie można spełnić tego wymagania
--- Koniec kodu ---

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej