Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Tumbleweed - nie moge ustawic zarządcy ondemand na stałe  (Przeczytany 548 razy)

Offline tony

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: 0
Tumbleweed - nie moge ustawic zarządcy ondemand na stałe
« dnia: Grudzień 25, 2020, 11:13:32 am »
Hej,

Chcę zmienić zarządcę intel_pstate na ondemand, na stałe. Teraz jest shcedutil i cąły czas trzyma CPU na taktowaniu miedzy max a turbo.
Wydaje komendę:

sudo  cpupower frequency-set -g ondemand
I jest ok, ale po restarcie znowu schedutil.
Jest dużo wątków na różnych forach, co zrobić, ale nic nie działa.
Nie jestem zbyt biegły w Linuxie, nie rozumiem, co powinienem zrobić.
System chodzi bardzo ładnie, ale zamęcza procesor domyślnymi ustawieniami.

Może cie mi podpowiedzieć, co doinstalować, zmienić?

Poniżej kilka komend, które znalazłem, może coś Wam powiedzą, czegoś chyba brakuje, bi nie mogę uruchomić usługi wraz ze startem systemu.

cpupower frequency-info
analyzing CPU 0:
  driver: intel_cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 20.0 us
  hardware limits: 800 MHz - 2.70 GHz
  available cpufreq governors: ondemand performance schedutil
  current policy: frequency should be within 800 MHz and 2.70 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.31 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes


sudo cat /etc/default/cpupower
cat: /etc/default/cpupower: Nie ma takiego pliku ani katalogu


sudo systemctl status cpupower
Unit cpupower.service could not be found.

sudo systemctl enable cpupower.service
Failed to enable unit: Unit file cpupower.service does not exist.

Wg komendy to mam intel_cpufreq a nie intel_pstate. Nie wiem już jak to ogarnąć.
To, co wrzuciłem jest pewnie trochę chaotyczne, to dlatego, że nie ogarniam tych ustawień procesora.

Pozdrawiam

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3123
  • Reputacja: 49
Odp: Tumbleweed - nie moge ustawic zarządcy ondemand na stałe
« Odpowiedź #1 dnia: Grudzień 25, 2020, 02:49:40 pm »
Wprawdzie nie z Zuśki, ale zerknij sobie na: https://wiki.archlinux.org/index.php/CPU_frequency_scaling. W miarę dobrze wytłumaczone. Sekcja dotycząca ustawienia na stałe winna być w 100% taka sama w SUSE jak w Archu.

Offline tony

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: 0
Odp: Tumbleweed - nie moge ustawic zarządcy ondemand na stałe
« Odpowiedź #2 dnia: Grudzień 28, 2020, 11:20:26 am »
Hej,

Dzięki za odpowiedź, załatwiłem sprawę dodając opcję "cpufreq.default_governor=ondemand" do GRUB-a.
Opcja dostępna tylko od kernel 5.9.

Pozdrawiam