Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Brak płynnego odtwarzania multimedia przeglądarki  (Przeczytany 1631 razy)

Offline kemot334

  • Newbie
  • *
  • Wiadomości: 14
  • Reputacja: 0
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #15 dnia: Październik 29, 2020, 10:41:45 pm »
Video z nośnika dvd czy zewnętrznego pendrive działa poprawnie
opera nie odtwarza video z innych stron tylko z youtub
video pobrane przez pobieracz.net działa poprawnie
problem nie dotyczy wyłącznie cda na innych stronach podanych wcześniej jest to samo na wet na stronach z porno
uważam że to problem jakiś kodeków albo wtyczek

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3073
  • Reputacja: 48
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #16 dnia: Październik 30, 2020, 10:54:56 am »
A mi to nadal wygląda na kwestię leżącą po stronie łącza.
Opera - o ile wiem - dla odtwarzania multimediów wymaga ffmpeg od chromium. W niektórych systemach są przygotowane odpowiednie paczki, jak np. opera-ffmpeg-codecs w Archu. FF używa ffmpeg. Nie wiemy jakim odtwarzaczem multimedialnym odtwarzasz filmy "lokalne", ale te najczęściej korzystają również ffmpeg lub mpv lub mpeg. VLC ma własne.
Zainstaluj sobie może chromium lub nawet chrome i sprawdź na nim (bo będziesz miał tam owe kodeki).
Sprawdź sobie jakość łącza internetowego.
Raczej natomiast wykluczone jest, by problem istniał po stronie sterowników do GPU.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1628
  • Reputacja: 9
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #17 dnia: Październik 30, 2020, 03:14:36 pm »
Z tego co pamiętam to w mincie była taka pozycja w menu "zainstaluj dodatkowe kodeki", czy jakoś tak. Sprawdzałeś to?
Arch Linux Xfce+compiz - 64Bit Linux User #621110 

Offline kemot334

  • Newbie
  • *
  • Wiadomości: 14
  • Reputacja: 0
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #18 dnia: Październik 30, 2020, 10:47:44 pm »
Z tego co pamiętam to w mincie była taka pozycja w menu "zainstaluj dodatkowe kodeki", czy jakoś tak. Sprawdzałeś to?
Sprawdzałem takiego czegoś nie znalazłem znalazłem Menadżera sterowników, Rozszerzenia,  Zasoby oprogramowania, natomiast nic o dodatkowych kodekach.

Zainstalowałem Chromium Web Browser i cda działa płynnie ( teraz co zrobić aby działało na operze )
Opera Stabel nie odtwarza niczego oprócz youtub
FF dalej brak płynnego odtwarzania na playerach

a odtwarzacze posiadam  celluloid, odtwarzacz mpv, rythmbox, VLC

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3073
  • Reputacja: 48
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #19 dnia: Październik 31, 2020, 07:51:21 am »
Nt. Opery - masz prawdopodobną odpowiedź wyżej.
FF - być może to jakieś ustawienia jego. Tu jednak zbyt słabo się znam, by Ci pomóc. Wiem jedynie, że w sieci są poradniki jak "przyspieszyć" FF.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3073
  • Reputacja: 48
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #20 dnia: Listopad 03, 2020, 02:35:46 pm »
Na wstępie - przepraszam za post pod postem, ale inaczej kemot334 nie zobaczy, że coś miałem jeszcze do dodania.

Przyszło mi do głowy, że:
1. Problem może być związany z brakiem odpowiedniego firmware/microcode. Niestety nie wiem jak ta paczka nazywa się w Mint. Szukaj coś z "intel" i "firmware" bądź "ucode" w nazwie. Może ktoś, kto ma system z rodziny debianowatych będzie Ci tu w stanie podrzucić cokolwiek.
2. Akceleracja. Masz taką włączoną?
Prawdopodobny, odpowiedni wpis dla Ciebie to:
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   #Option      "AccelMethod"  "uxa"
   #Option      "AccelMethod"  "xaa"
EndSection
który należy wprowadzić do pliku 20-intel.conf w lokalizacji: /etc/X11/xorg.conf.d - jeśli pliku nie ma - należy go utworzyć. Znów jednak - niech się wypowie ktoś, kto ma debianowaty system, czy ta lokalizacja jest również prawidłowa w takich.
Możesz próbować zmieniać "Option" poprzez kolejne postawienie znaku "#" i usunięcie z następnej linii (ma być jedno "Option" "AccelMethod" i albo to ma być "sna", albo "uxa", albo "xaa".
3. OpenGL
Nie wiem jak w środowisku, które masz, ale niekiedy jest możliwość wyboru pomiędzy różnymi wersjami OpenGL (najczęściej to 2.0 lub 3.1), a nawet Xrandr (choć zasadniczo OpenGL nie powinien mieć wpływu na odtwarzanie filmów).
4. Akceleracja sprzętowa. Tu znów - ktoś z debianowatych niech podpowie jak się nazywa stosowny plik - dla Twojego komputera prawdopodobnie właściwą paczką może być coś, co u mnie nazywa się libva-driver-intel (ogólnie sprawdź pod "libva" i "intel"). Nie powinno to już wymagać jakiejkolwiek konfiguracji, a jedynie restartu systemu. Być może to być jednak inna paczka - na tyle dobrze nie znam się na układach Intela.

Offline ciubaka

  • Hero Member
  • *****
  • Wiadomości: 579
  • Reputacja: 5
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #21 dnia: Listopad 03, 2020, 11:45:17 pm »
Kurcze dlaczego skoro działa chromium to Kolega upiera się żeby koniecznie zadziałało opera albo firefox? Czy to jest rodzaj samobiczowania czy samoumartwiania? To jest niestety linux, tu wiele rzeczy zadziała zupełnie inaczej niż w windows. Z tym trzeba pogodzić się albo nie. Skoro działa chromium to wybierz coś opartego na chromium, na przykład slimjet, albo coś innego, na przykład chromium. Skoro nie działa firefox i opera to nie męcz się dalej. Nie wiem jak opera bo nie używam już od dawna, ale firefox to i na windows potrafi nieźle zamulać. Więc proponuję używać tego co działa i nie stwarza problemów, to zawsze jest łatwiejsze niż odkrywanie Ameryki. Zwłaszcza że ona odkryta już jest :-(

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 3073
  • Reputacja: 48
Odp: Brak płynnego odtwarzania multimedia przeglądarki
« Odpowiedź #22 dnia: Listopad 04, 2020, 01:52:26 am »
Opera jest o chromium oparta :) Tyle, że kodeków nie zainstalował.
Z całą resztą się zgodzę. Brać, co działa.