Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Test klawiatury przy sparkylinux-5.12-i686-xfce i...  (Przeczytany 151 razy)

Offline os.y

  • Newbie
  • *
  • Wiadomości: 42
  • Reputacja: +0/-0
Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« dnia: Październik 06, 2020, 06:18:40 pm »
Jaka jest porzyczyna przemapowania klawiatury przy teście w czasie instalacji sparkylinux-5.12-i686-xfce na laptopie Fujitsu Siemens AMILO Pi 1536 ?
Ustawiony był język polski jako podstawowy oraz klawiatura standardowa : qwerty i qwertz
Zamiast liter : [óÓ/oO] jest [6], [u/U] jest [4], [i/I] jest 5, [ł/Ł] jest [3], [p/P jest [-].
Podobny problem występuje z kilkoma znakami interpunkcyjnymi.
Zmiana klawiatury z systemowej na podłączanej przez USB dała identyczne wyniki.
Spróbowałem też klawiatur językowych : English (us) i (uk) - róznica tylko ta, ze inne cyferki się wyświetlały po naciśnięciu klawiszy literek.
Obie klawiatury są w standardzie US-programisty.
Pozdrawiam.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2575
  • Reputacja: +35/-9
Odp: Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« Odpowiedź #1 dnia: Październik 07, 2020, 07:53:08 am »
Wyłącz NumLock

Offline os.y

  • Newbie
  • *
  • Wiadomości: 42
  • Reputacja: +0/-0
Odp: Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« Odpowiedź #2 dnia: Październik 07, 2020, 08:18:26 am »
Szokująca właściwa informacja / podpowiedź / odpowiedź.
Ze skóry by mnie obdzierali a tej zależnosci bym się nigdy nie domyślił.
Wątku jeszcze przez chwilę nie zamykam gdyż z przyjemnością przeczytał bym coś o przyczynie tej zależnosci.

pavbaranov... serdeczne dzięki

Offline os.y

  • Newbie
  • *
  • Wiadomości: 42
  • Reputacja: +0/-0
Odp: Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« Odpowiedź #3 dnia: Październik 07, 2020, 09:56:39 am »
Uzupełnienie :
Przy pierwszym uruchomieniu pojawia się opcja uruchomienia aktualizacji systemu z komunikatem o potrzebie uwierzytelnienia wydającego takie polecenie.
Wpisałem hasło i... nic.
Pomny po czasie o potrzebie wyłączenia NumLocka stosownie, na wszelki wypadek, go nacisnąłem, ponownie wpisałem hasło (które zahaczało o "zabronione literki"), zatwierdziłem decyzję i ... aktualizacja ruszyła.
Niby nic, taki drobiazg a i na ten szczegół przeglądajac dostępne mi info nie natrafiłem lub przeoczyłem.
Pozdrawiam nowicjuszy.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2575
  • Reputacja: +35/-9
Odp: Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« Odpowiedź #4 dnia: Październik 07, 2020, 11:36:16 am »
Jeśli dobrze pamiętam tego Amilo, to ma on klawiaturę bez odrębnej klawiatury numerycznej. Nie pamiętam jego BIOSu kompletnie. Nie wiem też, jak w xfce jest konfiguracja numlock przy jego starcie, ale przyczyny uruchamiania się środowiska z klawiaturą numeryczną zwykle są dwie:
1. Opcja w BIOSie, która to wprowadza.
2. Opcja w samym środowisku.
W pierwszym przypadku - sprawdź ustawienia BIOSu - jeśli jest by włączał klawiaturę numeryczną - po prostu wyłącz. Jeśli nadal będzie się uruchamiać przy starcie, to oznacza, że tak jest ustawione w xfce. To na tyle konfigurowalne środowisko, że w jego ustawieniach prawdopodobnie znajdziesz odpowiednie ustawienie, a w razie czego np. Robert pomoże.
Wątpię by to ustawienie wprowadził Paweł w jakimś skelu. W razie czego sprawdź wartość tak jak tu: https://wiki.archlinux.org/index.php/Activating_numlock_on_bootup#Xfce - "value" w obu przypadkach ma być "false" lub w ogóle nie powinno być takiego wpisu.

Offline os.y

  • Newbie
  • *
  • Wiadomości: 42
  • Reputacja: +0/-0
Odp: Test klawiatury przy sparkylinux-5.12-i686-xfce i...
« Odpowiedź #5 dnia: Październik 07, 2020, 03:32:38 pm »
Ze stronki : https://wiki.archlinux.org/index.php/Activating_numlock_on_bootup#Xfce
dowiedziałem się, że...

Xfce

In the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml
---- _en
, make sure the following values are set to true:
---- _pl (tłumaczenie Google Translator)
, upewnij się, że następujące wartości są ustawione na true:
----
<property name="Numlock" type="bool" value="true"/>
<property name="RestoreNumlock" type="bool" value="true"/>
----- _en
Note: If the file does not exist then open Settings > Keyboard, then check and uncheck the Restore num lock state on startup. This will create the keyboards.xml file.
----- _pl (tłumaczenie Google Translator)
Uwaga: jeśli plik nie istnieje, otwórz Ustawienia> Klawiatura, a następnie zaznacz i odznacz opcję Przywróć stan num lock przy uruchamianiu. Spowoduje to utworzenie pliku keyboards.xml.

I tak też i zrobiłem, tzn odznaczyłem ptaszka przy opcji "Przywróć stan num lock przy uruchamianiu." gdy pliku keyboards.xml wcześniej nie odnalazłem.
Oryginalny plik zawierał wpis:
-<channel name="keyboards" version="1.0">
  -<property name="Default" type="empty">
     <property name="Numlock" type="bool" value="false"/>
     <property name="RestoreNumlock" type="bool" value="false"/>
   </property>
 </channel>
ale nie dał sie skopiować jako taki (z tymi minusami w dwu pierwszych linijkach) a jedynie w wersi :
<channel name="keyboards" version="1.0">
<property name="Default" type="empty">
<property name="Numlock" type="bool" value="false"/>
<property name="RestoreNumlock" type="bool" value="false"/>
</property>
</channel>

Ponieważ wszystko wskazywało na to, że wszystko w pożądku więc zrestartowałem system i po jego uruchomieniu problem NumLock-a tak się sam i dzięki podpowiedzi pavbaranova rozwiązał.
Wielkie dzięki.

P.S. Na tak odpalonym Sparky próbowałem ten tekścik umieścić na forum dzięki wbudowanemu Firefoxowi ale z jakiegoś mi nieznanego powodu strona linuxiarze.pl i owszem się normalnie odpaliła ale już podstronka forum.linuxiarze.pl od 10 minut ani myśli więc standardowo wiec spod XPeka ten wpis umieszczam i temat zamykam mając nadzieję, ze może komuś te informacje także pozwolą identyczny problemik rozwiązać.