Interfejs graficzny > Inne pulpity

Compiz ciąg dalszy

(1/3) > >>

damian788:
Dzisiaj mi przyszedł nowy dysk. A że stary dysk na którym miałem kaliego był hdd konieczny był kolejny reinstall. Ale pomyślałem sobie że po co instalować tego compiza 0.8.13 z synaptica jak mogę zainstalować 0.9.13. I jak zwykle mam problem z kompilacją. Naściągałem całą stertę wymaganych bibliotek. Synaptic naprawdę okazał się błogosławieństwem, ale i tak nie mam pojecia jak to zakończyć.
[Spoiler (Rozwiń)quote]CMake Deprecation Warning at cmake/CompizCommon.cmake:19 (cmake_policy):
  The OLD behavior for policy CMP0011 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.
Call Stack (most recent call first):
  cmake/CompizPlugin.cmake:57 (include)
  plugins/workspacenames/CMakeLists.txt:3 (include)
[/quote]
Spoiler (Rozwiń)
--- Cytuj ---   GLESv2                         : No
   gtk window decorator           : No
   metacity theme support         : No
   gnome                          : Yes
   kde4 window decorator          : No
   protocol buffers               : Yes
   file system change notifications : Yes
   Xig Tests                      : No

--- Koniec cytatu ---
Spoiler (Rozwiń)
--- Cytuj ---[Plugin configure check results:

  addhelper     : Yes
  animation     : Yes
  animationaddon: Yes
  annotate      : No (Missing dependencies :)
  bench         : Yes
  bicubic       : Disabled
  blur          : No (Missing dependencies :)
  ccp           : Yes
  clone         : Yes
  colorfilter   : Disabled
  commands      : Yes
  compiztoolbox : Yes
  composite     : Yes
  copytex       : Yes
  crashhandler  : Yes
  cube          : Yes
  cubeaddon     : Yes
  dbus          : No (Missing dependencies :)
  decor         : Yes
  expo          : Yes
  extrawm       : Yes
  ezoom         : Yes
  fade          : Yes
  fadedesktop   : Yes
  firepaint     : Yes
  freewins      : No (Missing dependencies :)
  gears         : Yes
  gnomecompat   : Yes
  grid          : Yes
  group         : Disabled
  imgjpeg       : No (Missing dependencies :)
  imgpng        : No (Missing dependencies :)
  imgsvg        : No (Missing dependencies :)
  inotify       : Yes
  kde           : No (Missing dependencies :)
  kdecompat     : Yes
  loginout      : Disabled
  mag           : Yes
  matecompat    : Yes
  maximumize    : Yes
  mblur         : Yes
  mousepoll     : Yes
  move          : Yes
  neg           : Yes
  notification  : No (Missing dependencies :)
  obs           : Yes
  opacify       : Yes
  opengl        : Yes
  place         : Yes
  put           : Yes
  reflex        : Disabled
  regex         : Yes
  resize        : Yes
  resizeinfo    : No (Missing dependencies :)
  ring          : Yes
  rotate        : Yes
  scale         : Yes
  scaleaddon    : Yes
  scalefilter   : Yes
  screenshot    : Yes
  session       : Yes
  shelf         : Yes
  shift         : Yes
  showdesktop   : Yes
  showmouse     : Yes
  showrepaint   : Yes
  snap          : Yes
  splash        : Yes
  stackswitch   : Disabled
  staticswitcher: Yes
  switcher      : Yes
  td            : Yes
  text          : No (Missing dependencies :)
  thumbnail     : Yes
  titleinfo     : Yes
  trailfocus    : Yes
  trip          : Disabled
  vpswitch      : Yes
  wall          : No (Missing dependencies :)
  wallpaper     : Yes
  water         : Yes
  widget        : Yes
  winrules      : Yes
  wizard        : Yes
  wobbly        : Yes
  workarounds   : Yes
  workspacenames: Yes
/quote]

--- Koniec cytatu ---
Spoiler (Rozwiń)
--- Cytuj ---************************************************************

WARNING:
"FindCompiz.cmake" file not found in cmake module directories.
It should be installed to allow building of external compiz packages.
Call "sudo make findcompiz_install" to install it.

************************************************************

WARNING:
"FindCompizConfig.cmake" file not found in cmake module directories.
It should be installed to allow building of external compiz packages.
Call "sudo make findcompiz_install" to install it.

************************************************************

-- No coverage report targets set, not generating coverage report
-- Configuring incomplete, errors occurred!

--- Koniec cytatu ---

oczywiście
--- Cytuj ---sudo make findcompiz_install
--- Koniec cytatu ---
próbowałem ale nie znajduje findcompiz_install
Mógłbym sobie darwać i zainstalować wczesniejszą wersję ale zauwazyłem że np teraz instalowałem te całe paczki z x11 a na wczesniejszej wersji wyświetlało mi błedy w konsoli XI not exsistion i pewnie dlatego nie miałem modeli delfinów w kostce itp. Synapthic tego nie pokazywał a w konsoli praktycznie wszystko mi wyświetla co jest nie tak. Mogę jeszcze pokazac zawartość plików CmakeError.log i CmakeOutput.log jeżeli to pomoże.

pavbaranov:
Sugerowałbym Ci znalezienie jakiejś paczki np. w PPA, a jak widać one są:
--- Kod ---https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3924-deletedppa/+build/18693243
--- Koniec kodu ---
(o ile obecnie Kali oparte na Ubuntu). Kompilacja na łapu capu, po tygodniu używania linuksa ma dość średni sens.
Jeśli nie, to posiłkować się możesz tym jak to skompilować czytając np. PKGBUILD:
--- Kod ---https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=compiz
--- Koniec kodu ---
sekcja build odpowiada za kompilację, package za instalację (czyli tradycyjnie odpowiada to make install). Zwróć jednak na to ile jest patchy nałożonych; co najmniej część wydaje się być mocno potrzebna.
PS: Jeśli potrzebujesz w istocie najnowszych paczek, to na Twoim miejscu od początku darowałbym sobie Kali i zabawił w jakąś dystrybucję rolling release. Podobną rolę do Kali pełni np. BlackArch.

robson75:

--- Kod ---https://www.keefto.com/view/article/6VhYhFbUsCX8
--- Koniec kodu ---

damian788:
Pierwszy sposób to dla mnie trochę czarna magia, ale w linkach jest build 0.9.14 a ja mam instalkę 0.9.13. Chyba zainstaluje 2 sposobem robsona tylko to mi pobierze wersje 0.8+ bo już to kiedyś próbowałem ale trudno czasami lepiej miec świety spokój. Na pierwszym sposobie pewnie musiałbym spędzić kolejne godziny jak nie dni...

robson75:
Nie dodawaj tego repa, bo w nim jest tylko wersja 0.8.14. A myślałem że najnowsza.

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej