Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: [Mint 20] Problem po instalacji  (Przeczytany 161 razy)

Offline kubatron

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: +0/-0
[Mint 20] Problem po instalacji
« dnia: Wrzesień 01, 2020, 12:34:46 pm »
Witam,

Dzisiaj postanowiłem zainstalować Mint'a obok Win10.
Robiłem to chyba z 5x i za każdym razem ten sam scenariusz.

Może nakreślę jak wygląda mój sprzęt:
Hyperbook SL503VR
Intel i7-7700Q
GeForce GTX1060
2x SSD
PNY 500GB - slot PCIe NVMe 4 x3
WD240GB - slot SATA 2.5

Na PNY zainstalowany mam Win 10 - dwie partycję , systemowa 103 Gb, dane 359 gb (C: i D: )

WD jest dodatkowym dyskiem przeznaczonym na inne dane, nie jest podzielony, całość jako E:

Więc dzisiaj postanowiłem spróbować.
Ściagnięty MINT 20 Cinnamon , poprzez Rufus na pendrive zobrazowałem go według wszystkich poradników ( pendrive to adapter kart do którego mam włożoną kartę SanDisc Extreme Pro ).

Pierwsze podzieliłem partycję D: na dwie , została D: oraz E: o wielkości 100GB na Mint'a, tzn. wydzieliłem miejsce 100GB bez przydzielania partycji - wolna przestrzeń.

Zbootowałem pena po restarcie, uruchomiłem Mint'a z wyświetlonego ekranu i z pulpitu zainicjowałem ikonę Zainstaluj Minta (piszę w skrócie), wszystkie kroki po kolei wykonywałem do momentu wyboru instalacji i wybrałem Użyj innego sposobu - tu według poradników "wolną przestrzeń" podzieliłem na 3 partycję , ROOT ("/") na 40GB, WYMIANY 16GB (RAM mam 16GB), oraz resztę to /Home.

no i wszystko super fajnie cudownie, malina, zainstalowało się, zresetował komputer, wyświetlił ekran wyboru Minta , windowsa i opcji zaawansowanych, wybrałem Minta, i się uruchomił , podałem hasło i wszstko niby grało...do czasu gdy zaproponował mi instalację sterowników, wyświetliły mi się stery do Nvidii , wybrałem odpowiednie ZALECANE, później przy kolejnej instalacji wybrałem inne i bum...koniec świata.

Po restarcie zawisł...no więc ekran startowy po uruchomieniu ponownym i wybraniu opcji zaawansowanych i wybraniu RECOVERY czy jakoś tak opcji Linux'a uruchomił się linux i po chwili znów to samo.

Później próbowałem zainstalować go na tym samym dysku co Win10, wydzieliłem z partycji D: - 100GB przestrzenii i to samo.

Później całkowicie cały dysk WD 240GB przeznaczyłem na niego - to samo.

I jeszcze chyba dwa razy próbowałem ale odchodzi mi ochota jak mam tracić czas niewiedząć czy ja jestem głupi, czy coś źle ustawionego w BIOS'ie mam, czy po prostu nie wiem.

Proszę o pomoc.

P.S. Nie neguję Linux'a ale podjarałem się wszystkim co oglądałem na jego temat, czytałem o jego stabilności i tym podobne w stosunku do Windows'a i inne kwestie ale na razie to trochę mnie rozczarowuję , chociaż wybrałem dystrybucję, która jest podobno jedną z stabilniejszych obok Ubuntu.


Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2507
  • Reputacja: +32/-8
Odp: [Mint 20] Problem po instalacji
« Odpowiedź #1 dnia: Wrzesień 01, 2020, 01:40:24 pm »
Duży opis, a konkretnie to lekko mało treści.
Rozumiem, że:
1. Mint jest zainstalowany; podczas instalacji zainstalował sobie jakieś sterowniki (lub nie) i działał najprawdopodobniej na Intelu lub na sterownikach Nouveau (o tym jeszcze niżej),
2. Zainstalowałeś sterowniki "Zalecane", czyli prawdopodobnie nvidia.
I tyle wiemy oraz skutek: czarny ekran, ale nie wiemy:
1. Masz tzw. grafikę hybrydową, czy nie?
2. Czy po instalacji sterowników "zalecanych", system startuje (piszesz coś o "kolejnej instalacji" - nie wiadomo czego jednak, systemu, sterowników? - wyborze innych /rozumiem, że sterowników/ i o końcu świata; zatem nie wiemy, czy system pracuje na sterownikach nvidii.
3. Jakie sterowniki "zalecane" wskazał instalator?

PS: Proponuję mimo wszystko ruszyć dysk WD na instalacje, bo masz zdecydowanie mniejsze prawdopodobieństwo, że coś przy okazji popsujesz sobie z Win10, a szkoda byłoby.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1436
  • Reputacja: +7/-0
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: [Mint 20] Problem po instalacji
« Odpowiedź #2 dnia: Wrzesień 01, 2020, 02:14:54 pm »
no i wszystko super fajnie cudownie, malina, zainstalowało się, zresetował komputer, wyświetlił ekran wyboru Minta , windowsa i opcji zaawansowanych, wybrałem Minta, i się uruchomił , podałem hasło i wszstko niby grało...do czasu gdy zaproponował mi instalację sterowników, wyświetliły mi się stery do Nvidii , wybrałem odpowiednie ZALECANE, później przy kolejnej instalacji wybrałem inne i bum...koniec świata.
Wniosek z tego taki żebyś nie instalował tych sterów do grafiki, a system i tak będzie działał. Odkąd pamiętam z nvidią zawsze były problemy na linuxie.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2507
  • Reputacja: +32/-8
Odp: [Mint 20] Problem po instalacji
« Odpowiedź #3 dnia: Wrzesień 01, 2020, 06:22:25 pm »
Robert ma rację. Sterowniki zainstalowane domyślnie, to najprawdopodobniej nouveau (poczytaj), sterowniki "zalecane" - to najprawdopodobniej własnościowe nvidia. Jeśli:
1. nie jesteś graczem,
2. nie używasz komputera do zaawansowanej obróbki wideo (nie wiem jak sobie nouveau radzą z obróbką zdjęć),
3. nie używasz komputera do zaawansowanych obliczeń, gdzie GPU służy jako "dodatkowy" procesor i potrzebne Ci CUDA,
to w istocie - zostań przy nouveau, a ewentualnie w przyszłości, jak obeznasz system, okiełznasz go, zapoznasz się z podstawami korzystania z niego i zrozumiesz co i jak tu funkcjonuje, to wówczas zmień na nvidia.

PS: Sprawdź sobie jeszcze jedno. Zgodnie ze stroną https://www.nvidia.pl/Download/driverResults.aspx/163406/pl, sterownik nvidia dla Twojej karty to wersja 450.66 (ostatni), który jest dość świeżo wydany (połowa sierpnia br.). Jaki masz w tym Mincie (Ubuntu)?
« Ostatnia zmiana: Wrzesień 01, 2020, 06:25:49 pm wysłana przez pavbaranov »