Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu  (Przeczytany 279 razy)

Offline Milczarskivon

  • Newbie
  • *
  • Wiadomości: 18
  • Reputacja: +0/-0
Witam xorg nie chce wstać na sterowniku radeon który mam zamiar używać i muszę używać vesy

Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 17 19:09:20 2020
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] drm report modesetting isn't supported.



xorg log

[  1122.455] (II) [KMS] drm report modesetting isn't supported.
[  1122.455] (EE) Screen 0 deleted because of no matching config section.
[  1122.455] (II) UnloadModule: "radeon"
[  1122.455] (EE) Device(s) detected, but none match those in the config file.
[  1122.455] (EE)
[  1122.455] (EE) Device(s) detected, but none match those in the config file.
[  1122.455] (EE)
Fatal server error:
[  1122.455] (EE) no screens found(EE)
[  1122.455] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  1122.455] (EE) Please also check the log file at "/var/log/Xorg.0.log" for a$[  1122.455] (EE)
[  1122.456] (EE) Server terminated with error (1). Closing log file.
 
« Ostatnia zmiana: Lipiec 17, 2020, 08:56:38 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2507
  • Reputacja: +32/-8
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #1 dnia: Lipiec 17, 2020, 08:57:53 pm »
Pokaż config grubego

Offline Milczarskivon

  • Newbie
  • *
  • Wiadomości: 18
  • Reputacja: +0/-0
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #2 dnia: Lipiec 17, 2020, 09:00:19 pm »
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="rootflags=data=writeback radeon.si_support=1 radeon.dpm=1 radeon.modeset=1 acpi=off"
GRUB_CMDLINE_LINUX_DEFAULT=" radeon.modeset=1 rootflags=data=writeback hpet=force clocksource=hpet vga=radeon"
#GRUB_CMDLINE_LINUX_DEFAULT="rootflags=data=writeback radeon.modeset=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
« Ostatnia zmiana: Lipiec 17, 2020, 09:04:20 pm wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2507
  • Reputacja: +32/-8
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #3 dnia: Lipiec 17, 2020, 09:04:45 pm »
W jakim celu używasz m.in.: GRUB_CMDLINE_LINUX_DEFAULT=" radeon.modeset=1

Offline Milczarskivon

  • Newbie
  • *
  • Wiadomości: 18
  • Reputacja: +0/-0
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #4 dnia: Lipiec 17, 2020, 09:12:06 pm »
pojawi się następny błąd który występuje tylko na nowym kernelu ale jest krytyczny i uniemożliwia wstanie iksów ani dostępu do konsoli



kernel się zawiesza na

VGA devicee added decodes=io+mem , owns=i

Offline Milczarskivon

  • Newbie
  • *
  • Wiadomości: 18
  • Reputacja: +0/-0
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #5 dnia: Lipiec 17, 2020, 09:32:12 pm »
 dmesg | grep radeon
Cytuj
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.6.14-miko root=UUID=52e1d01d-38d2-4209-9265-f688a20f15ec ro radeon.modeset=0 rootflags=data=writeback hpet=force clocksource=hpet vga=radeon
[    0.085480] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.6.14-miko root=UUID=52e1d01d-38d2-4209-9265-f688a20f15ec ro radeon.modeset=0 rootflags=data=writeback hpet=force clocksource=hpet vga=radeon
[    1.210990] [drm:radeon_init] *ERROR* No UMS support in radeon module!
[    2.397076]     vga=radeon

Offline Milczarskivon

  • Newbie
  • *
  • Wiadomości: 18
  • Reputacja: +0/-0
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #6 dnia: Lipiec 17, 2020, 11:53:01 pm »
W jakim celu używasz m.in.: GRUB_CMDLINE_LINUX_DEFAULT=" radeon.modeset=1


jak odpalam sterownik radeon na domyślnym kernelu to tak musi być i to włącza albo wyłącza kmsa niewiem ...sam powiedz ...ABY ODPALIĆ GRUBA NA NOWYM KERNELU MUSZĘ TU WSTAWIĆ ZERO

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2507
  • Reputacja: +32/-8
Odp: błąd xorga [KMS] drm report modesetting isn't supported na nowym kernelu
« Odpowiedź #7 dnia: Lipiec 18, 2020, 07:51:15 am »
Są sprzeczne informacje, z tych, które podajesz (raz - w GRUB masz radeon.modeset=1, z logu wychodzi radeon.modeset=0). Wg wiki Archa parametru vga=X w ogóle nie powinno być.