Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: [ROZWIĄZANY]Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI  (Przeczytany 331 razy)

Offline Sławek719

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Witam wszystkich,

Chcę zainstalować Lubuntu 20.04 LTS na laptopie Acer, na którym preinstalowany był Win 10. Po usunięciu Windowsa zainstalowałem linuksa „normalnie” i wtedy dowiedziałem się, że istnieje coś takiego jak UEFI. Zrobiłem wszystko tak jak w tym poradniku:

https://linuxiarze.pl/podzial-dysku-uefi/

Po restarcie nadal mam czarny ekran z komunikatem „No bootable device”. Wyłączyłem secure boot i nadal to samo, zainstalowałem ponownie z wyłączonym i znowu widzę czarny ekran.

Czy jedyną opcją w tym przypadku jest zainstalowanie systemu w trybie legacy?
Będę wdzięczny za każdą sensowną odpowiedź.

Pozdrawiam
« Ostatnia zmiana: Czerwiec 24, 2020, 08:22:26 pm wysłana przez Sławek719 »

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2550
  • Reputacja: +35/-8
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #1 dnia: Czerwiec 24, 2020, 11:12:42 am »
Jak instalowałeś ten system? Z informacji wynika, że albo nie zainstalowałeś bootloadera (w Lubuntu domyślnie, to chyba GRUB) albo... w ogóle nie zainstalowałeś systemu. Jak w większości dystrybucji, także i w Lubuntu jest dość łopatologiczna instrukcja instalacji: https://docs.lubuntu.net/lubuntu_installation
« Ostatnia zmiana: Czerwiec 24, 2020, 11:14:23 am wysłana przez pavbaranov »

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1451
  • Reputacja: +8/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #2 dnia: Czerwiec 24, 2020, 11:29:27 am »
A czy dodałeś do boot/efi flagę esp?
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline Sławek719

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #3 dnia: Czerwiec 24, 2020, 11:53:54 am »
Najlepiej będzie, gdy przedstawię to w sposób graficzny.

Tak wygląda tablica partycji przed i po instalacji:
https://ibb.co/gP4xDWv

A tak wygląda okno instalatora i tym samym sposób, w który instalowałem system:
https://ibb.co/bRpvhdL

Jak widać system jest już zainstalowany ale nie startuje.
« Ostatnia zmiana: Czerwiec 24, 2020, 12:06:32 pm wysłana przez Sławek719 »

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2550
  • Reputacja: +35/-8
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #4 dnia: Czerwiec 24, 2020, 12:39:11 pm »
Nie wiem, gdzie Ty widzisz, że "jak widać system jest już zainstalowany".
Raz jeszcze - w linku podanym przeze mnie masz całą instrukcję instalacji Lubuntu, także w przypadku UEFI.
Jeśli system jest zainstalowany można ewentualnie użyć jakiegoś narzędzia typu boot-repair, grub-repair itp., które być może są przynajmniej w repozytorium Ubuntu. Nie wiem, bo nie mam. Na "piechotę" sporo roboty i musiałbyś się zapoznać z czymś o wdzięcznej nazwie chroot systemu.

Offline Sławek719

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #5 dnia: Czerwiec 24, 2020, 01:48:11 pm »
Cytuj
Nie wiem, gdzie Ty widzisz, że "jak widać system jest już zainstalowany".

Na drugim screenie są dwa paski przedstawiające w sposób graficzny partycje na dysku. Na pierwszym z nich jest odcinek zaznaczony kolorem żółtym, gdzie w legendzie jest opisany jako Ubuntu 20.04 LTS. Czyli jak widać system jest już zainstalowany, gdyż instalator poprawnie go wykrywa.

Na moje oko wszystko jest zrobione tak jak w tutorialu, do którego link mi wysłałeś. Zamieściłem link do screena z obrazem partycji, bo myślałem, że może coś zrobiłem nie tak jak trzeba. Jeśli to jest w porządku, to widocznie będę musiał zainstalować samego GRUB-a raz jeszcze...

Online pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2550
  • Reputacja: +35/-8
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #6 dnia: Czerwiec 24, 2020, 02:31:45 pm »
No fakt, mea culpa. Proste rozwiązanie: zainstaluj raz jeszcze system postępując zgodnie z instrukcją. Przy tej okazji można również pomyśleć o stworzeniu partycji /home - przydaje się. Alternatywa - jw.
« Ostatnia zmiana: Czerwiec 24, 2020, 02:44:04 pm wysłana przez pavbaranov »

Offline D35CART35

  • Newbie
  • *
  • Wiadomości: 40
  • Reputacja: +1/-0
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #7 dnia: Czerwiec 24, 2020, 02:59:19 pm »
@pavbaranov  na błędach się człowiek uczy.  ;)

Offline Sławek719

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #8 dnia: Czerwiec 24, 2020, 07:45:58 pm »
Zrobiłem krok po kroku to, co w tutorialu z linku od pavbaranov i nadal przy rozruchu widzę czarny ekran z napisem "No bootable device".
Zainstalowałem ponownie GRUB-a z instrukcji na stronie
https://linuxsuperuser.com/reinstall-grub2-efi-bootloader-ubuntu/
i nadal ten sam komunikat.
Podczas instalacji GRUB-a wszystko przebiegło poprawnie, żadnych błędów. Zarówno przed jak i po instalacji UUID na /dev/sda1 się zgadzał.
 Powoli tracę nadzieję na poprawną instalację w trybie UEFI.

Czy instalacja Lubuntu 20.04 LTS w trybie legacy nie przysporzy później problemów w normalnym użytkowaniu?
« Ostatnia zmiana: Czerwiec 24, 2020, 07:52:29 pm wysłana przez Sławek719 »

Offline Sławek719

  • Newbie
  • *
  • Wiadomości: 5
  • Reputacja: +0/-0
Odp: Lubuntu 20.04 LTS, problem z uruchomieniem na laptopie Acer z UEFI
« Odpowiedź #9 dnia: Czerwiec 24, 2020, 08:21:13 pm »
Rozwiązałem problem :)
Postąpiłem zgodnie z instrukcją ze strony
https://askubuntu.com/questions/886536/how-to-install-ubuntu-on-an-acer-with-preinstalled-windows-10-home
I system się uruchomił. Wystarczyło w Biosie wskazać plik SHIMX64.EFI jako zaufany do wykonania przy włączonej opcji "Secure boot"

Dzięki z pomoc i pozdrawiam