Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Pamac uniemożliwia aktualizację Archa  (Przeczytany 1397 razy)

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Pamac uniemożliwia aktualizację Archa
« dnia: Październik 23, 2019, 08:58:24 pm »
Jakiś czas temu przeszedłąm łagodnie z Antergosa na Archa według doskonałej instrukcji pavbaranowa.
Do dnia dzisiejszego wszystko było doskonale. Aktualizacje przez [pacman] bezproblemowe, i od czasu do czasu odnowienie [mirrors] za pomocą [reflector]
Dziś po wpisaniu "pacman -Syu" otrzymałem następujący komunikat:

:: Synchronizowanie baz danych z pakietami…
 core jest aktualne
 extra jest aktualne
 community jest aktualne
 multilib jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja pacman (5.2.0-2) uszkodzi zależności 'pacman<5.2' wymagane przez pamac

Co robić?
Wydaje mi się, że powinienem usunąć coś w którymś z programów aby aktualizacja ruszyła, ale co i gdzie?
« Ostatnia zmiana: Październik 25, 2019, 02:51:55 pm wysłana przez Piejanto »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2563
  • Reputacja: +35/-9
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #1 dnia: Październik 23, 2019, 09:06:34 pm »
Problem nie ma nic wspólnego z Archem. Używasz pamac, który jest pomysłem Manjaro i jest dostępny również w AUR. Problem, z jakim się spotkałeś wynika z tego, że w Archu pojawiła się nowa wersja pacmana, do której wersja pamac, którą masz jest niedostosowana. Być może wystarczy przebudowanie pamac, być może zbudowanie nowszej wersji. Musisz to jednak zrobić "na piechotę", albowiem pamac Ci w tym nie pomoże.
Używając AUR zawsze jesteś opiekunem swojej, lokalnej wersji Archa. Musisz dbać o nią. Inaczej działać nie będzie prawidłowo.
Oczywiście nie byłbym sobą, gdybym nie stwierdził, że od wszelakich nakładek na pacmana, rozszerzających jego działanie na AUR najlepszy jest polski wynalazek pn. pak dostępny w POLAUR. Działa 100/100.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1453
  • Reputacja: +8/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #2 dnia: Październik 23, 2019, 10:02:46 pm »
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja pacman (5.2.0-2) uszkodzi zależności 'pacman<5.2' wymagane przez pamac
Musisz usunąć pamaca (i tak nie będzie działał pod nowym pacman-em), ja też do dzisiaj używałem pamac-classic, ale niestety po aktualizacji pacman-a w ogóle on się nawet nie uruchamia. Trzeba będzie poczekać aż dostosują pamac-a do pacman-a.

PS.
Jest w AUR vpacman jeżeli potrzebujesz GUI managera pakietów (działa on pod nowym pacman-em, bo dzisiaj sprawdzałem).
Tylko po zbudowaniu vpacman musisz wykonać komendę
pkgfile --update
« Ostatnia zmiana: Październik 23, 2019, 10:23:58 pm wysłana przez robson75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2563
  • Reputacja: +35/-9
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #3 dnia: Październik 24, 2019, 07:54:17 am »
Wersja 9.0.1-3 powinna być już dostosowana do pacman >=5.2. W tej wersji pamac znajduje się w repozytoriach archlinuxcn i chaotic-aur. Nie trzeba wówczas budować lokalnie.

Offline robson75

  • Hero Member
  • *****
  • Wiadomości: 1453
  • Reputacja: +8/-1
  • Nie ufaj nikomu w sieci, nawet mi.
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #4 dnia: Październik 24, 2019, 12:54:21 pm »
Wersja 9.0.1-3 powinna być już dostosowana do pacman >=5.2. W tej wersji pamac znajduje się w repozytoriach archlinuxcn i chaotic-aur. Nie trzeba wówczas budować lokalnie.
Masz rację Pawle.
Ja używam repa archlinuxcn, i wczoraj była jeszcze wersja pamac-aur 9.0.1-2, a dzisiaj już jest 9.0.1-3 (i działa). Widać że osoby odpowiedzialne za to repo nie tracą czasu.

Edit
Pamac-classic w AUR też już jest dostosowany do nowego pacman-a.
« Ostatnia zmiana: Październik 24, 2019, 01:06:26 pm wysłana przez robson75 »
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #5 dnia: Październik 24, 2019, 01:55:16 pm »
pavbaranov
Wiem że wierzgnięcie nie ma niczego wspólnego z Archem, ale w tym stwierdzeniu zawarłem mój pierwszy problem od czasu porzucenia Antergosa.
Skoro pamac jest pomysłem Manjaro, to jasne, ze wolałbym go wyrzucić, ale nie wiedziałem czy można.
Z AUR boję się korzystać, gdyż sam mówiłeś, że "małorolni wieśniacy" nie powinni raczej korzystać z rzeczy przeznaczonych dla ludzi reprezentujących jakiś, średni przynajmniej, poziom intelektualny. Ale teraz spróbuję się zapoznać z POLAUR-em, a w szczególności produktem pod nazwą pak.
Menagera GUI raczej nie używam, a jeśli nawet to nieświadomie.
Podstawowe pytanie na teraz brzmi:
Czy jeśli po prostu wyrzucę pamac-a, to nie stanie mi się krzywda?
« Ostatnia zmiana: Październik 24, 2019, 01:58:17 pm wysłana przez Piejanto »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2563
  • Reputacja: +35/-9
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #6 dnia: Październik 24, 2019, 03:21:52 pm »
Na ostatnie pytanie - nie - nie stanie się krzywda ani Tobie, ani systemowi, ani komputerowi. Pamac(-aur/classic) to jest swego rodzaju nakładka na pacman (w zasadzie to zdaje się, że na libalpm), która umożliwia zarządzanie tak paczkami z repozytorium (czyli jest w tym zakresie odpowiednikiem pacman), jak i AUR. Dodatkowo oferuje GUI.
Jeśli nie jest dla Ciebie istotne GUI, nie używasz AUR, to po prostu pozostań przy pacman lub... zainstaluj sobie pak.

Kilka uwag nt. pak.
Pak (ten z POLAUR, bo pojawiła się również paczka o takiej nazwie w AUR, a to 2 różne rzeczy) to również nakładka na pacmana, rozszerzająca jego możliwości m.in. o AUR. W zakresie obsługi repozytoriów pak po prostu korzysta z pacmana. Wywołanie - powiedzmy pak -S paczka dokonuje wywołania pacmana ze składnią: pacman -Syu paczka. Pak nie zawiera żadnych "sztuczek", nie korzysta z nieudokumentowanych rzeczy w libalpm. Teraz o zaletach i wadach pak (przy założeniu, że zainstalujesz zależności opcjonalne pak, które znacznie rozszerzają jego funkcjonalność).
Zalety (to m.in.):
1. Instalowanie czegokolwiek przez pak nigdy nie doprowadzi do tzw. częściowej aktualizacji systemu. Wywołanie instalacji paczki za pomocą pak spowoduje zaktualizowanie systemu, a następnie zainstalowanie paczki. Podobnie pak zachowuje się w przypadku instalacji (czyt. budowania) czegokolwiek z AUR i POLAUR.
2. Pak - jak już widać - obsługuje także AUR i POLAUR. Budując paczki z nich dokonuje dokładnie tego samego, co użytkownik zrobić by musiał, gdyby ręcznie budował paczkę z AUR: klonuje repozytorium danego programu, wchodzi do pobranego katalogu, wywołuje makepkg budując paczkę, następnie pozwala na instalację jej i usunięcie zbędnych zależności, jak również wyczyszczenie katalogów budujących paczkę. Brak tu jakichkolwiek sztuczek - krok po kroku wywołuje instrukcje. Nadto umożliwia walidację tak PKGBUILDu jak i zbudowanej paczki (przez namcap).
3. Umożliwia aktualizacje tzw. mirrorów dla pacmana (przez reflector).
4. Umożliwia ściągnięcie PKGBUILDów tak dla paczek z repo (przez abs), jak i z AUR.
5. Zachowuje składnię pacmana w wysokim stopniu, choć np. pak -S paczka znaczy pacman -Syu paczka.
6. Umożliwia przeszukiwanie tak AUR, jak i POLAUR. O repo nie wspomnę, to oczywiste.
7. Umożliwia łatwe uzyskanie informacji o zmianach w zakresie paczek zainstalowanych lokalnie.
8. Umożliwia uzyskanie informacji, czy paczki z CVS (np. te, z "git" na końcu) mogą zostać zaktualizowane do nowszych wersji skutkiem pojawienia się nowych źródeł.
9. Umożliwia informację o dostępnych aktualizacjach paczek ze wszystkich źródeł obsługiwanych przez pak.
10. Podaje informacje o tzw. niescalonych plikach (chodzi o paczki, które dostarczają plików - najczęściej konfiguracyjnych - np. z pacnew w nazwie).
11. Umożliwia przeczyszczenie systemu z kopii odinstalowanych paczek.
12. Pak nigdy nie zawiesi swego działania ze względu na nową wersję pacman, jaka się pojawia w repo. Po prostu skorzysta z nowszej wersji. (Sytuacja z jaką się spotkałeś z pamac nigdy nie będzie miała miejsca).
I jeszcze kilka innych rzeczy pewnie by się znalazło.
Wady:
1. Budując paczkę z AUR, która wymaga wcześniejszego zbudowania paczki również z AUR nie uczyni tego, a jedynie poinformuje o konieczności wcześniejszego zbudowania paczek.
2. W sumie nie wada, albowiem doszliśmy do wniosku, że szkoda robić coś, co już jest zrobione - korzysta niekiedy z innych paczek aby osiągnąć pełną funkcjonalność.

Jeśli pragniesz pak mieć, to musisz wywołać następującą linię (podaję dla pak, albowiem jest jeszcze pak-git, ale to jest w zasadzie wersja dla Damiana i dla mnie :)):
sudo pacman -S wget && mkdir pak && cd pak && wget https://raw.githubusercontent.com/polaur/new-branded/master/pak/PKGBUILD && wget https://raw.githubusercontent.com/polaur/new-branded/master/pak/CHANGELOG && makepkg -sircKatalog pak możesz wykasować, gdyż po zbudowaniu w ten sposób pak będziesz mógł jego aktualizacje wykonywać za jego pomocą.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #7 dnia: Październik 24, 2019, 09:20:23 pm »
pavbaranov

Fajnie. Usunąłem [pamac] i aktualizacja poszła pięknie.
Zniknęła mi z paska pozycja sygnalizująca dostępne aktualizacje, ale to nie jest problem, gdyż już teraz pilnuję tego sam.

Przy okazji restartu zauważyłem, że jako pierwsza pozycja podczas ładowania wyskakuje mi :

AntergosRoot: clean 5995...(wiele cyfr) files (wiele cyfr), a następne wersy ładowania już nie dotyczą Antergosa

Za to zauważyłem, że mam
          Programy/System/Antergos welcome
oraz
          Programy/System/Grub Customizer
a tam po kliknięciu zaczyna się ładowanie [skryptu 4/7 (antergos)].
  Po załadowaniu w oknie są pozycje [konfiguracja listy],
a w Konfiguracji Listy mam pozycje:
 Antergos Linux (wpismenu / skrypt antergos)
następnie katalog
[Advanced options for Antergos Linux (podmenu)]
a pod nim
 Antergos Linux
       (wpismenu / skrypt antergosa)
Antergos Linux-Fallback
        (wpismenu / skrypt antergosa)
Antergos Linux LTS Kernel
        (wpismenu / skrypt antergosa)
Antergos Linux LTS Kernel-Fallback
        (wpismenu / skrypt antergosa)

Po wejściu w Grub Customizer-ustawienia
mam zaznaczoną jako włączoną m.in. pozycję
[GRUB-DISTRIBUTOR .........Antergos]

Oczywiście pak-a sobie zainstaluję.
Dzięki za instrukcje i gotowce do wklejania.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2563
  • Reputacja: +35/-9
Odp: Pierwsze wierzgnięcie Archa
« Odpowiedź #8 dnia: Październik 25, 2019, 07:49:40 am »
AntergosRoot: clean 5995...(wiele cyfr) files (wiele cyfr), a następne wersy ładowania już nie dotyczą Antergosa
Nie wiem o co chodzi - musiałbym zobaczyć coś więcej.
Za to zauważyłem, że mam
          Programy/System/Antergos welcome
No to zdecydowałeś się pozostawić w systemie, to masz.
          Programy/System/Grub Customizer
Paczka grub-customizer jest w community. Nie ma nic wspólnego z Antergosem.
  Po załadowaniu w oknie są pozycje [konfiguracja listy],
a w Konfiguracji Listy mam pozycje:
 Antergos Linux (wpismenu / skrypt antergos)
następnie katalog
[Advanced options for Antergos Linux (podmenu)]
a pod nim
 Antergos Linux
       (wpismenu / skrypt antergosa)
Antergos Linux-Fallback
        (wpismenu / skrypt antergosa)
Antergos Linux LTS Kernel
        (wpismenu / skrypt antergosa)
Antergos Linux LTS Kernel-Fallback
        (wpismenu / skrypt antergosa)
Bowiem tak został sobie GRUB skonstruowany. Nie ma to wpływu na nic, ale jak chcesz, to można się tym pobawić. Nie jest to związane np. z kernelami od Antergosa, albowiem takich on - o ile wiem - nie dostarczał. Osobiście w ogóle GRUB nie używam już bodaj drugi rok i jestem zadowolonym użytkownikiem "nie"-GRUBa :)

Można przeszukać system pod kątem wszystkich paczek, które mają coś wspólnego z Antergos oraz znaleźć wszystkie wpisy gdziekolwiek, które odwołują się do Antergos. Jeśli będziesz chciał - daj znać.

PS: Zmień temat wątku, bo on nic nie mówi (np. na Pamac uniemożliwia aktualizację Archa).
PS2: Wydaje się, że problem z pamac został zażegnany, a teraz pojawia się inna kwestia, która chyba winna być częścią wątku o przechodzeniu z Antergosa na Archa i tam powinna być kontynuowana.

Offline Piejanto

  • Sr. Member
  • ****
  • Wiadomości: 413
  • Reputacja: +0/-0
Odp: Pamac uniemożliwia aktualizację Archa
« Odpowiedź #9 dnia: Październik 25, 2019, 02:49:14 pm »
pavbaranov
Zrobione. Zmieniłem tytuł.
zainstalowałem pak-a. Teraz muszę się w tym porozglądać jak to działa i przyzwyczaić do nowości.
Na netbooku powiedział mi, że aby zaktualizować AUR, musi mieć zainstalowany auracle-git. Doinstalowałem ale chyba na razie nie wiem co z tym robić.

Co do tych różności w GRUB, to jasne, że nie mam sensu w tym kopać jeśli to nie przeszkadza.

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2563
  • Reputacja: +35/-9
Odp: Pamac uniemożliwia aktualizację Archa
« Odpowiedź #10 dnia: Październik 25, 2019, 03:37:52 pm »
Na netbooku powiedział mi, że aby zaktualizować AUR, musi mieć zainstalowany auracle-git. Doinstalowałem ale chyba na razie nie wiem co z tym robić.
Nic. Po prostu używaj :)