Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Nie mogę zainstalować apt  (Przeczytany 1240 razy)

Offline biotyt12

  • Newbie
  • *
  • Wiadomości: 2
  • Reputacja: +0/-0
Nie mogę zainstalować apt
« dnia: Lipiec 13, 2019, 01:11:12 am »
Witam, mój system to Sparkylinux minimal gui, na starym laptopie: dell Latitude 131l. Wszystko ładnie mi działało, dopóki nie pokusiłem się, o pełną aktualizację systemu i może jeszcze gdzieś namieszałem i pojawił się błąd aktualizacji:
Cytuj
Nowsza wersja spary5-apt jest dostępna. Ten pakiet musi być zaktualizowany przed innymi
i występuje nadal .Próbowałem porady z tej strony: https://linuxiarze.pl/jak-przeksztalcic-sparkylinux-testing-na-stable/ i różnych innych, natomiast sudo sudo apt-get update: rw@rw-pc:~$ sudo apt-get update
[sudo] hasło użytkownika rw:
Stary:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease                           
Stary:3 http://www.deb-multimedia.org stretch InRelease                       
Pobieranie:4 http://ftp.debian.org/debian stretch Release [118 kB]             
Pobieranie:5 http://ftp.debian.org/debian stretch Release.gpg [2434 B]
Pobieranie:6 https://sparkylinux.org/repo stable InRelease [6540 B]
Błąd:6 https://sparkylinux.org/repo stable InRelease     
  Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 1CE63BD7D117204E
Stary:7 http://ftp.debian.org/debian stretch/non-free Sources
Stary:8 http://ftp.debian.org/debian stretch/contrib Sources
Stary:9 http://ftp.debian.org/debian stretch/main Sources
Stary:10 http://ftp.debian.org/debian stretch/main i386 Packages
Stary:11 http://ftp.debian.org/debian stretch/main Translation-en
Stary:12 http://ftp.debian.org/debian stretch/main Translation-pl
Stary:13 http://ftp.debian.org/debian stretch/contrib i386 Packages
Ign:7 http://ftp.debian.org/debian stretch/non-free Sources
Ign:8 http://ftp.debian.org/debian stretch/contrib Sources
Ign:9 http://ftp.debian.org/debian stretch/main Sources
Ign:10 http://ftp.debian.org/debian stretch/main i386 Packages
Ign:11 http://ftp.debian.org/debian stretch/main Translation-en
Ign:12 http://ftp.debian.org/debian stretch/main Translation-pl
Ign:13 http://ftp.debian.org/debian stretch/contrib i386 Packages
Stary:14 http://ftp.debian.org/debian stretch/contrib Translation-en
Stary:15 http://ftp.debian.org/debian stretch/non-free i386 Packages
Stary:16 http://ftp.debian.org/debian stretch/non-free Translation-en
Ign:14 http://ftp.debian.org/debian stretch/contrib Translation-en
Ign:15 http://ftp.debian.org/debian stretch/non-free i386 Packages
Ign:16 http://ftp.debian.org/debian stretch/non-free Translation-en
Stary:7 http://ftp.debian.org/debian stretch/non-free Sources                 
Ign:7 http://ftp.debian.org/debian stretch/non-free Sources                   
Stary:8 http://ftp.debian.org/debian stretch/contrib Sources                   
Ign:8 http://ftp.debian.org/debian stretch/contrib Sources                     
Stary:9 http://ftp.debian.org/debian stretch/main Sources                     
Ign:9 http://ftp.debian.org/debian stretch/main Sources                       
Stary:10 http://ftp.debian.org/debian stretch/main i386 Packages               
Ign:10 http://ftp.debian.org/debian stretch/main i386 Packages                 
Stary:11 http://ftp.debian.org/debian stretch/main Translation-en             
Stary:12 http://ftp.debian.org/debian stretch/main Translation-pl             
Stary:13 http://ftp.debian.org/debian stretch/contrib i386 Packages           
Ign:11 http://ftp.debian.org/debian stretch/main Translation-en               
Ign:12 http://ftp.debian.org/debian stretch/main Translation-pl               
Ign:13 http://ftp.debian.org/debian stretch/contrib i386 Packages             
Stary:14 http://ftp.debian.org/debian stretch/contrib Translation-en           
Stary:15 http://ftp.debian.org/debian stretch/non-free i386 Packages           
Stary:16 http://ftp.debian.org/debian stretch/non-free Translation-en         
Stary:7 http://ftp.debian.org/debian stretch/non-free Sources                 
Ign:8 http://ftp.debian.org/debian stretch/contrib Sources                     
Ign:14 http://ftp.debian.org/debian stretch/contrib Translation-en             
Ign:15 http://ftp.debian.org/debian stretch/non-free i386 Packages             
Ign:16 http://ftp.debian.org/debian stretch/non-free Translation-en           
Ign:9 http://ftp.debian.org/debian stretch/main Sources                       
Ign:10 http://ftp.debian.org/debian stretch/main i386 Packages                 
Błąd:11 http://ftp.debian.org/debian stretch/main Translation-en               
  BZ2_bzread: /var/lib/apt/lists/partial/ftp.debian.org_debian_dists_stretch_main_i18n_Translation-en.bz2 Błąd odczytu (-5: DATA_ERROR_MAGIC)
Ign:12 http://ftp.debian.org/debian stretch/main Translation-pl               
Stary:13 http://ftp.debian.org/debian stretch/contrib i386 Packages           
Ign:8 http://ftp.debian.org/debian stretch/contrib Sources                     
Ign:14 http://ftp.debian.org/debian stretch/contrib Translation-en             
Stary:15 http://ftp.debian.org/debian stretch/non-free i386 Packages           
Ign:16 http://ftp.debian.org/debian stretch/non-free Translation-en           
Ign:9 http://ftp.debian.org/debian stretch/main Sources                       
Ign:10 http://ftp.debian.org/debian stretch/main i386 Packages                 
Pobrano 127 kB w 8s (14,6 kB/s)                                               
Czytanie list pakietów... Gotowe
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://sparkylinux.org/repo stable InRelease: Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 1CE63BD7D117204E
W: Nie udało się pobrać https://sparkylinux.org/repo/dists/stable/InRelease  Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY 1CE63BD7D117204E
E: Nie udało się pobrać http://ftp.debian.org/debian/dists/stretch/main/i18n/Translation-en  BZ2_bzread: /var/lib/apt/lists/partial/ftp.debian.org_debian_dists_stretch_main_i18n_Translation-en.bz2 Błąd odczytu (-5: DATA_ERROR_MAGIC)
W: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.
rw@rw-pc:~$
.
 Kiedy wchodzę w system o sparkylinux (informacja) to wyświetla mi że system jest w wersji  5.8 Nibiru, a chcę wersję stabilną. Czy może ktoś pomóc?
« Ostatnia zmiana: Lipiec 13, 2019, 08:36:02 am wysłana przez lami07 »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2519
  • Reputacja: +32/-8
Odp: Nie mogę zainstalować apt
« Odpowiedź #1 dnia: Lipiec 13, 2019, 02:03:37 am »
Się grzecznie spytam: wykonałeś https://wiki.archlinux.org/index.php/PRIME? Bo z tego co widzę, to nie. Ale Sparky to Twoja dystrybucja, nie moja :)

Offline PomPom

  • Hero Member
  • *****
  • Wiadomości: 1633
  • Reputacja: +1/-0
  • RAM RANCH REALLY ROCKS!
Odp: Nie mogę zainstalować apt
« Odpowiedź #2 dnia: Lipiec 13, 2019, 07:43:42 am »
Takie długie błędy wrzucaj na pastebin i podawaj link tylko.
Windows 10 | Arch Linux | Gentoo

Online arecki

  • Full Member
  • ***
  • Wiadomości: 160
  • Reputacja: +0/-0
Odp: Nie mogę zainstalować apt
« Odpowiedź #3 dnia: Lipiec 13, 2019, 09:31:55 am »
Brak kluczy do repozytorii sparky, łap link https://sparkylinux.org/repo/pool/main/s/sparky-keyring/
Ewentualnie rób update z opcją --allow-insecure-repositories
Debian testing.