Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Jaki Linux do gier, steam?  (Przeczytany 2568 razy)

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2876
  • Reputacja: 46
Odp: Jaki Linux do gier, steam?
« Odpowiedź #15 dnia: Lipiec 13, 2019, 05:19:57 pm »
Sprawdź zatem na sesji Xów. Jeśli masz GNOME to możesz je wywołać bez najmniejszych problemów zarówno w Wayland, jak i w Xach. Będziesz przynajmniej wiedział, czy problemem jest Wayland/XWayland.

Offline funn

  • Jr. Member
  • **
  • Wiadomości: 91
  • Reputacja: 0
Odp: Jaki Linux do gier, steam?
« Odpowiedź #16 dnia: Lipiec 13, 2019, 09:13:22 pm »
Wcześniej napisałeś, że nie ma zamkniętych sterowników do tej karty graficznej. Na tej stronie są Catalyst 15.9 wydane w 2015 roku.
https://www.amd.com/en/support/graphics/amd-radeon-hd/
Czy chodziło Ci o to, że otwarte sterowniki Radeon z 2019 będą wydajniejsze od tych staroci Catalyst? Co objawi się większą ilością fps w grach. Wiem to było 3-4 lata temu, ale nie znalazłem aktualnych porównań.
https://www.youtube.com/watch?v=Eg8QHlrF4EA
https://www.youtube.com/watch?v=bYMaVrsbg2w
« Ostatnia zmiana: Lipiec 13, 2019, 09:21:23 pm wysłana przez funn »

Offline pavbaranov

  • Hero Member
  • *****
  • Wiadomości: 2876
  • Reputacja: 46
Odp: Jaki Linux do gier, steam?
« Odpowiedź #17 dnia: Lipiec 13, 2019, 11:26:18 pm »
Napisałem i wiem co piszę. Masz Archa. Sterowniki Catalyst są:
1. dla wcześniejszych wersji Xów, niż wersja dostępna w Archu; musiałbyś cofnąć Xy, a i to niekoniecznie dałoby dobry efekt, gdyż - jak każde rolling release - Arch nie wspiera częściowej aktualizacji,
2. Catalyst jest porzuconym bodaj 4 lata temu rozwiązaniem, od tego czasu AMD mocno współpracuje z OS i dodało/dodaje cały stock sterowników bezpośrednio do kernela,
3. porzucenie kodu przez upstream, przy jednocześnie zamkniętej wersji kodu oznacza, że nie masz jakiegokolwiek wsparcia ze strony nikogo dla tych sterowników, z uwagi na to, że ostatnia wersja wyszła na linuksy sprzed 4 lat, a nawet Ubuntu 14.04 już zakończyło swój żywot, to nie możesz liczyć nawet na poprawki bezpieczeństwa,
4. sterownik ATI (Radeon) otwartoźródłowy jest obecnie co najmniej tak samo wydajny jak stary Catalyst.
Stąd też - sterowników własnościowych dla starych Radeonów obecnie, dla współczesnej dystrybucji. Są dla GCN>=3 sterowniki amdgpu-pro, jednakże niekoniecznie one sprawdzą się w rozwiązaniach dla graczy, a na pewno nie są dla Twojego Radeona.

Raz jeszcze nie jestem graczem i nie ekscytuję się ilością fpsów, jakie w nich będą. Chcesz mieć więcej - zainstaluj lepsze GPU. Rozwiązanie ze starym, niewspieranym sterownikiem nie ma natomiast wg mnie absolutnie najmniejszego sensu m.in. ze względów bezpieczeństwa.