Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Lenovo IdeaPad 330 nie chce działać z linuxem

Zaczęty przez korn85, Luty 13, 2019, 11:03:14 PM

Poprzedni wątek - Następny wątek

korn85

#45
Radość trwała zbyt długo, właśnie WiFi przestało działać :-[ Zainstalowałem jeszcze raz sterownik karty WiFi ale nic to nie dało, internet jest tylko po kabelku, w ogóle nie pokazuje połączeń bezprzewodowych :(

Ok problemem okazał się nowszy kernel 4.20.13. Poprzedni 4.20.12 nie robi problemów z WiFi. Poza tym nowy nie działa :o Po włączeniu laptopa w konsoli pojawia się komunikat, że najpierw trzeba wczytać jądro... W Yast zmieniłem ustawienia rozruchu aby domyślnie startował ze starszym jądrem :)

pavbaranov

Problemem - prawdopodobnie - nie jest kernel, ale to, że sterownik dla niego nie został przebudowany. Spróbuj znaleźć sterownik dla swojej karty w "formacie" dkms, a wówczas przy każdej zmianie kernela zostanie on przebudowany, albo musisz znaleźć repozytorium, które dostarcza sterownik w wersji zgodnej z kernelem.

korn85

Tak właśnie sądziłem :) Tylko dlaczego z nowym kernel laptop nie startuje? Po włączeniu laptopa pojawia się logo Lenovo, później opcje startu Tumbleweed i po odliczeniu 5s (tyle sobie ustawiłem) pojawia się konsola i komunikat, że najpierw trzeba wczytać jądro. Domyślnie Zuśka ma startować na kernelu 4.20.13 ale tego nie robi. Jak wybiorę starszy kernel wszystko się uruchamia jak należy.

pavbaranov

Bez logów - nic wiedzieć nie będziemy. Nikt nie jest wróżką. W poprzednim poście napisałeś, że nie działa na nowym kernelu wifi - stąd, by to wiedzieć, kernel musiał się uruchomić. Teraz piszesz, że w ogóle nie startuje. Ja po tych informacjach wiem jedynie, że są ze sobą sprzeczne.

korn85

Już tłumaczę. Po aktualizacji do 4.20.13 i restarcie laptop ruszył ale nie działało WiFi. Później go wyłączyłem i po ponownym włączeniu za kilka godzin już nie odpalił najnowszy kernel. Obecnie kernel zaktualizował się do wersji 5.0.0-1 i również na nim nie startuje. Pojawia się komunikat jak na zdjęciu.

http://uploadfile.pl/pokaz/1663592---ncr4.html

http://uploadfile.pl/pokaz/1663595---qxg1.html

Co sprawdzić, jakie komendy? :)

pavbaranov

Aktualizację kernela zawsze kończy restart komputera. Przed jego dokonaniem, w ogóle nie ma sensu rozważanie co się dzieje, bowiem w istocie coś może nie działać prawidłowo.
Zdjęcie pierwsze to jak sądzę zdjęcie jakiegoś programu rozruchowego.
Zdjęcie drugie wskazuje na błędną instalację kernela. Czy to kernel z oficjalnego repozytorium? Zerknij na: https://forums.opensuse.org/showthread.php/495681-Grub2-Invalid-signature-error-when-multi-booting ale ogólnie wydaje się to być problem do zgłoszenia jako błąd po stronie deweloperów Zuśki i nie ma absolutnie nic wspólnego z brakiem kompatybilności między sprzętem a kernelem > 4.20.12.

ciubaka

Czy próbowaleś startować w trybie recovery (fallback czy jak go tam zwał u Ciebie)?
Jeżeli startuje w tej konfiguracji to będzie błąd programu rozruchowego (grub, czy jak tam masz skonfigurowane - coś zdaje się zmieniałeś w ustawieniach bios i uefi).
Jeżeli nie startuje  - to raczej system się zainstalował niepoprawnie.
Ale raczej rozruch - pisałeś że pokazuje jakieś niepokojące Cię komunikaty przy starcie i zamykaniu systemu.
Nie lepiej to było stawiać Suse na domyślnych ustawieniach BIOS?
I jeszcze jedno moje prywatne spostrzeżenie - jak próbowałem kiedyś Suse to też miałem kłopoty z wifi.
Postawiłem Gecko i nie było problemów.
Wiem że Gecko jest od pół roku nie aktualizowane, ale jednak było łatwiejsze w obsłudze.
To samo miałem z Debianem i Centos.
Po prostu wydaje się, że pewne rzeczy w systemach pochodnych są lepiej dopracowane niż w bazowych.
Albo lepiej rzecz nazywając - łatwiej skonfigurowane.

pavbaranov

@ciubaka - To nie jest problem GRUBa. Problem jest znany w kilku dystrybucjach i związany z weryfikowaniem podpisów kernela (startującego).
Jeśli zaś chodzi o niedziałające wifi po "aktualizacji kernela", to z opisu wynika, że prawdopodobnie zostały wgrane nowe sterowniki (które zaczęły   pracować), ale nie został dokonany restart komputera (co jest w takim przypadku konieczne). Do chwili uruchomienia komputera na nowym kernelu nie wiemy, czy istnieje z nimi problem.
Gecko nie jest absolutnie (przynajmniej w wersji stable oraz w wersji rolling, ale bezpośrednio po jego wgraniu) dystrybucją właściwą dla konfiguracji tego komputera.

korn85

Witam Forumowiczów! :) Po dłuższym korzystaniu z Tumbleweed mogę coś więcej napisać. System startuje szybko, działa również bezproblemowo. Obecnie nurtują mnie dwa problemy.
1. TorBrowser. Po instalacji i kliknięciu na "cebulkę" przy kursorze pojawia się kółeczko jakby wczytywał się program, po czym kółeczko znika, a Tora nie ma.
2. Drukarka HP OfficeJet 6830 nie skanuje do komputera. Jest skonfigurowana po WiFi i drukuje bez zarzutu. Również mam dostęp do danych jak ilość tuszu. Niestety skanowanie do komputerka nie działa :(
Ktoś coś doradzi? :)

Piotr_1988

Cytat: korn85 w Maj 13, 2019, 08:59:11 PM
1. TorBrowser. Po instalacji i kliknięciu na "cebulkę" przy kursorze pojawia się kółeczko jakby wczytywał się program, po czym kółeczko znika, a Tora nie ma.
Mi się w ogóle nie udało zainstalować Tora na Linuxie... Korzystam z Tora w wersji bez instalacji, którą wystarczy rozpakować i u mnie działa bezproblemowo.
Fedora Silverblue 36  |  EndeavourOS

pavbaranov

@korn85 - Nie rób bur... załóż 2 nowe wątki dotyczące dwu nowych problemów.

Zobacz najnowsze wiadomości na forum