Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

LMDE3 Monitory -> Mint 19.1 Mate dalej problem Monitorów

Zaczęty przez studenciak_na_mincie, Marzec 07, 2019, 11:40:34 PM

Poprzedni wątek - Następny wątek

studenciak_na_mincie

Witam Forumowiczów,

Mam problem ze świerzą instalacją LMDE3 otóż nie wykrywa drugiego monitora, na początku jest wszytko ok wyświetla grub-a na dwuch ekranach a po zalogowaniu drugi monitor "idzie spać" i tyle, w żadnych ustawieniach go nie widać i tak dalej... Co może być przyczyną? Dodam że na poprzednim mincie wszytko było ok, laptop działał pod dwoma monitorami bez zarzutu,

moje karty graficzne to:
zintegrowana Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
dedykowania [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

ciubaka

To kwestia ustawień, dosyć długo szarpałem się z tym na xubuntu i lubuntu oraz na mint cinnamon (tego to nawet poddałem), natomiast systemy z mate (gecko i ubuntu) chodziły od razu, bez grzebania. Również manjaro xfce pracował od pierwszego włączenia na dwóch monitorach. Tak że w zależności od tego co masz w systemie, musisz pobawić się jego ustawieniami (parametry wyświetlania, ekrany, coś tam, nie wiem jak to idzie w lmde, zwłaszcza że nie wiadomo które).

robson75

Cytat: ciubaka w Marzec 08, 2019, 07:37:06 AMnie wiem jak to idzie w lmde, zwłaszcza że nie wiadomo które).
Z tego co się orientuje to LMDE3 ma w chwili obecnej dostępne tylko jedno DE, czyli Cinnamon.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

pavbaranov

Być może Ci się przyda: https://wiki.archlinux.org/index.php/Multihead
Bliżej LMDE - zaglądnij do wiki Debiana, bowiem znając "fsparcie" Minta pewnie nic o tym w dokumentacji nie ma.
To pracujące (kiedy?) multihead prawdopodobnie jest ustawiane przy użyciu xorg.conf, albo... Cinnamon uruchomił Ci się z software'owym wyświetlaniem i wówczas nie miał problemów.
Ogólnie sprawdziłbym porównując działającą zgodnie z Twoimi oczekiwaniami i obecną instalację pod kątem:
1. Z jakiego sposobu wyświetlania Cinnamon korzysta ("software", czy "normalne")?
2. Z użyciem jakiego GPU wyświetla prawidłowo (masz tu PRIME - pytanie, czy skonfigurowane)?
Przede wszystkim odpowiedziałbym sobie jednak na pytanie, czy na pewno potrzebuję Minta zbudowanego wprost na Debianie. LMDE3 raczej nie ma zbyt pochlebnych opinii i rzeczy, które działają tak na Debianie, jak i na "zwykłym" Mincie zbudowanym na Ubuntu tutaj niekoniecznie nie sprawiają kłopotów. To ostatnie to pytanie retoryczne.

ciubaka

wybierz system settings / hardware / display i ustaw  konfiguracje ktora cie zadowoli
mozesz metoda prob i bledow
co prawda to z lmde2 rozwiazanie ale nie sadze zeby w lmde3 bylo inaczej
przepraszam za brak polskich czcionek ale pisze z lmde2 live na dwoch monitorach
ten drugi ustawiony na primary
pozdrawiam


studenciak_na_mincie

Te podstawowe ustawienia "przeklikałem" na samym początku. Z racji ze LMDE 3 trochę mnie wkurzyło jeszcze innymi rzeczami przeinstalowałem system na Minta 19.1 z środowiskiem graficznym MATE i dalej mam ten sam problem nie widzi (monitor podłączony do stacji dokującej na złączu DVI) lub nie wyświetla nic na monitorze podłączonym do złącza D-SUB  (Bezpośrednio pod laptop), Uruchamiałem tez laptop w różnych konfiguracjach grafiki, raz na zintegrowanej raz na dedykowanej i nic to nie dało. W biosie wszystko standardowo nic nie jest wyłączone w sensie żaden port albo coś. Niestety mój laptop ma już swoje lata i niekoniecznie są do niego dedykowane sterowniki graficzne, a jeżeli są to na starą wersję serwera Xorg, przez co nawet nie chcą się zainstalować.

Dodam że korzystam z jądra 4.15.0-46-generic(x86_64).

pavbaranov

Cytat: studenciak_na_mincie w Marzec 10, 2019, 02:34:07 PM
Te podstawowe ustawienia "przeklikałem" na samym początku.
Pokaż nam zatem owe konfiguracje. Pokaż również co się wpisuje do dziennika systemowego po podłączeniu drugiego monitora.
I jeszcze jedno sterownik Intela to modesetting, czy "intel"?

TataPingu

Cytat: studenciak_na_mincie w Marzec 10, 2019, 02:34:07 PM
i dalej mam ten sam problem nie widzi (monitor podłączony do stacji dokującej na złączu DVI) lub nie wyświetla nic na monitorze podłączonym do złącza D-SUB  (Bezpośrednio pod laptop)

Sama stacja może być problemem, niektóre typy wymagają dodatkowych sterowników..
- jeśli wszystkie inne interfejsy stacji funkcjonują, to prawdopodobnie to nie stacja...

Przy "bezpośrednim" podłączeniu, odczepiłeś lapka od stacji ?

Cytat: studenciak_na_mincie w Marzec 10, 2019, 02:34:07 PM
W biosie wszystko standardowo nic nie jest wyłączone w sensie żaden port albo coś

To też jest relatywne, niekiedy trzeba coś "załączyć" w BIOSie

Popróbuj z innymi dystrami, szczególnie z takimi, które oferują jeszcze w "standardzie" Xorga, np. Linux-MX

pavbaranov

@TataPingu - ale LMDE oferuje właśnie w "standardzie" XOrg :) Cinnamon na niczym innym się nie uruchomi. Fakt jednak można zerknąć na jakąś liveOS, zwłaszcza taki, który po prostu ma w ten sposób (czyli głównie bez instalacji na HDD) działać.

TataPingu


studenciak_na_mincie

Jak najbardziej spróbuje wszelkich waszych rad, aczkolwiek mam pewne przypuszczenia...
Obecny system instalowałem na laptopie bez stacji dokującej i bez żadnego monitora podpiętego, poprzedni system (Mint 19 Cinamon) raczej instalowałem w laptopie wpiętym w stacje. I oto moje pytanie czy jest możliwe że podczas instalacji system nie wykrył żadnych dodatkowych urządzeń przez co nie załadował potrzebnych składników do jądra?


A tak poza tym to wszystkie porty w stacji dokującej działają 

ciubaka

To nie powinno mieć wpływu. Raczej to jest uroda miętowych dystrybucji. Aczkolwiek u mnie wersja mate działa, cinnamon ni huhu. Zrób jak pisał TataPingu, odpal inna dystrybucję w wersji live i sprawdź. Ze swej strony mogę zapewnić, że - nieładne słowo - defaultowo u mnie działało na stacji dysków i dwóch monitorach Ubuntu Mate, Gecko Mate w wersji rolling i Manjaro XFCE. To przynajmniej masz wskazówkę i nie musisz kombinować co tu wartoby przetestować.

pavbaranov

Cytat: studenciak_na_mincie w Marzec 11, 2019, 11:37:37 PM
I oto moje pytanie czy jest możliwe że podczas instalacji system nie wykrył żadnych dodatkowych urządzeń przez co nie załadował potrzebnych składników do jądra?
Nie. Program instalacyjny przekopiował kernel znajdujący się na nośniku instalacyjnym na dysk twardy. Niczego w tym kernelu nie zmieniał i niczego do niego nie "ładował", bo nie ma i nie będzie mieć takiej możliwości bez rekompilacji kernela, co w przypadku takich dystrybucji jak LMDE nie następuje (w zasadzie to prawie w żadnej nie następuje).
Natomiast instalator mógł wykryć pewne urządzenia w jednym przypadku i podnieść odpowiednie usługi i nie uczynić tego w drugim przypadku (gdy ich nie było).
Nie ma to jednak znaczenia, gdyż problem może wynikać z:
- niewłaściwego kernela, który źle obsługuje Twoją konfigurację sprzętową (mało prawdopodobne, ale zainstaluj np. kernel xanmod i zobacz czy są jakieś zmiany),
- braku jakichś składników systemu (wątpliwe),
- niewłaściwego skonfigurowania systemu (najbardziej prawdopodobne, ale informacji od Ciebie brak, by Ci pomóc),
- niewłaściwego działania samego Cinnamona (jak najbardziej prawdopodobne).

Zobacz najnowsze wiadomości na forum