Dystrybucje Linux > Slackware

[Rozwiązany] Xrdp i X11rdp szwankuje na 14.2

(1/1)

Gienek:
Jest Slackware 64 14.2, zainstalowałem xrdp 0.6.1 (nowsze 0.94 ze Slackbuilda w ogóle nie chce mi współpracować z tym co w temacie) oraz X11rdp.
Vnc jest ok ale X11rdp zachowuje się to co najmniej dziwnie.
Pierwsze logowanie sesja startuje, wylogowuję się i po kolejnym logowaniu widzę tylko szary ekran.
Jeżeli zmienię rozdzielczość w rdesktopie  to ponownie wm (xfce4) startuje ale po wylogowaniu znowu szary ekran.
Nie będzie szarego ekranu gdy się rozłączam (zamykając okienko x).
Więc aby mieć dostęp muszę w kółko Macieju zmieniać rozdzielczość albo nie wylogowywać się tylko rozłączać.
Widzę też że tworzy nowe instancje X11rdp (pierwsze dwie linie poniżej) zamiast jechać w takim przypadku na jednej jak poczciwa 13.1.
Zmiana wm na inny  np. KDE nie wchodzi w rachubę.
 
--- Kod: ---  496 ?        S      0:00 X11rdp :10 -geometry 1920x1024 -depth 16 -bs -ac -nolisten tcp
12889 ?        S      0:00 X11rdp :11 -geometry 1920x1024 -depth 16 -bs -ac -nolisten tcp
13179 ?        S      0:00 X11rdp :12 -geometry 1920x1024 -depth 16 -bs -ac -nolisten tcp -depth 16
14511 ?        S      1:44 X11rdp :13 -geometry 800x600 -depth 16 -bs -ac -nolisten tcp -depth 16
15173 ?        S      0:13 X11rdp :14 -geometry 1024x768 -depth 16 -bs -ac -nolisten tcp
15494 pts/4    S      0:00 X11rdp :15 -geometry 800x600 -depth 24 -bs -ac -nolisten tcp
--- Koniec kodu ---

Czy udało się to komuś bezproblemowo uruchomić oczywiście na takiej wersji?

Na 13.1 64bit z KDE działa to bezproblemowo.
To nowe Xfce4 takie jakieś podkulawione nawet mousepada trzeba dorabiać.

Gienek:
Problem rozwiązany połowicznie, odpalam rdesktop bez parametru -g

Nawigacja

[0] Indeks wiadomości

Idź do wersji pełnej