Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: KVM - brak dostępu do gościa z LANu  (Przeczytany 634 razy)

Offline tidnab

  • Newbie
  • *
  • Wiadomości: 1
  • Reputacja: +0/-0
KVM - brak dostępu do gościa z LANu
« dnia: Wrzesień 03, 2018, 08:57:34 am »
Cześć

Mam taki problem. Ubuntu 18.04 server + KVM.
Zrobiony bridge.
br1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.226  netmask 255.255.255.0  broadcast 0.0.0.0
        inet6 fe80::922b:34ff:fe1d:b6e0  prefixlen 64  scopeid 0x20<link>
        ether 90:2b:34:1d:b6:e0  txqueuelen 1000  (Ethernet)
        RX packets 468840  bytes 32854377 (32.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 279398  bytes 4438870816 (4.4 GB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 90:2b:34:1d:b6:e0  txqueuelen 1000  (Ethernet)
        RX packets 468700  bytes 39402221 (39.4 MB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 3236944  bytes 4302333267 (4.3 GB)
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 118  bytes 8694 (8.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 118  bytes 8694 (8.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:5d:32:65  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ brctl  show
\bridge name    bridge id               STP enabled     interfaces
br1             8000.902b341db6e0       no              enp2s0
virbr0          8000.5254005d3265       yes             virbr0-nic

sysctl -p
net.ipv4.ip_forward = 1

Mam virtualke z ip 192.168.11   którą mogę pingować z hosta KVM ale nie mam do niej dostępu z LAN'u.