Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w wątku Administracja.
Wątki z problemami zamieszczone w dziale "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Autor Wątek: Nie mogę zainstalować pakietu mysql-server  (Przeczytany 982 razy)

Offline abdel

  • Newbie
  • *
  • Wiadomości: 1
  • Reputacja: 0
Nie mogę zainstalować pakietu mysql-server
« dnia: Luty 10, 2018, 12:34:42 pm »
Mam problem taki, że potrzebuje zainstalować mysql na moim serwerze. jednak polecenie apt-get install mysql-server zwraca taki komunikat błędu. Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-server : Depends: mysql-server-5.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Kiedy próbuję więc zainstalować wersje 5.5 zwraca coś takiegoSome packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-server-5.5 : Depends: libdbi-perl but it is not going to be installed
                    Depends: mysql-client-5.5 (>= 5.5.59-0ubuntu0.14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Zawartość pliku sources.list #+ Ubuntu Main Repos
deb http://01.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
deb-src http://01.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse

#+ Ubuntu Update Repos
deb http://01.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://01.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://01.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://01.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://01.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb-src http://01.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb-src http://01.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb-src http://01.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb http://nl.archive.ubuntu.com/ubuntu trusty-backports main restricted universe multiverse
Ma ktoś pomysł jak to naprawić? hosting digitalocean

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Wiadomości: 1739
  • Reputacja: 5
Odp: Nie mogę zainstalować pakietu mysql-server
« Odpowiedź #1 dnia: Luty 10, 2018, 02:35:19 pm »
Pakiet libdbi-perl jest dostępny w repo trusty, więc odśwież listę pakietów:
sudo apt-get updatei spróbuj go zainstalować:
sudo apt-get install libdbi-perli wrzuć wynik błędu, jeśli będzie problem.
Nic nie jest tak proste, jak się wydaje.
Danielle Steel