Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Instalacja (uruchamianie plików o rozszrzerzeniu sh.

Zaczęty przez terefenk, Sierpień 28, 2017, 06:35:21 PM

Poprzedni wątek - Następny wątek

pavroo

Nie napisałeś jaka to wersja Ubuntu.
Jednak po numerze wersji libpng16 wnioskuję, że zesty, a w repo zesty nie ma libpng12-0.
W takim wypadu ręcznie pobierz i zainstaluj pakiet libpng12-0 z repo trusty lub xenial:
https://packages.ubuntu.com/search?keywords=libpng12&suite=default&section=all&arch=any&searchon=names
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain


gom1

Kurczę, nie mam dobrych wieści. Tzn. zainstalowałem Lubuntu 17.04 w wersji 32-bitowej i uruchomiłem skrypt, ale wszystko poszło sprawnie, bez monitu o bibliotekę libpng w wersji 1.2. Tak jak na Sparky wystarczyła do tego wersja 1.6.

Spróbuj jak radzi @pavroo.
Wszędzie dobrze, ale w /home najlepiej

terefenk

Oto rezultat wykonania polecenia sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;

mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
[sudo] hasło użytkownika mikolaj:
mikolaj@mikolaj-AMILO-PRO-V8010:~$


Armalat

https://packages.ubuntu.com/search?suite=trusty&arch=any&mode=exactfilename&searchon=contents&keywords=libpng12.so.0
Stamtąd możesz pobrać

terefenk

To wynik wykonania polecenia: find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
mikolaj@mikolaj-AMILO-PRO-V8010:~$ sudo find / -name libpng12.so.0 2>/dev/null -exec ls -l {} \;
[sudo] hasło użytkownika mikolaj:
mikolaj@mikolaj-AMILO-PRO-V8010:~$

terefenk

Pobrałem ze stron wskazanych przez pawroo i Armalata pakiet libpng_1.2.50-1ubuntu2.14.04.2.debian.tar.bz2.
Zapisałem go w katalogu Pobrane. Udało mi się go rozpakować poleceniem tar -xvjf libpng_1.2.50-1ubuntu2.14.04.2.debian.tar.bz2.
Niestety próba jego kompilacji poleceniem ./ configure kończy się wyświetleniem komunikatu o treści:
mikolaj@mikolaj-AMILO-PRO-V8010:~/Pobrane$ ./configure
bash: ./configure: Nie ma takiego pliku ani katalogu
Prośba o pomoc w rozwiązaniu problemu możliwie w sposób krok po kroku.
Przy okazji informacja: korzystam z Lubuntu 17.04. Druga informacja - w Synaptic Menedżer Pakietów znajduje się pakiet libpng16-16, co wskazywałoby że został on zainstalowany.

pavroo

Pakiet 'libpng16' to nie to samo co 'libpng12', więc nie jest zainstalowany.
Nie pobieraj paczki z archiwami do kompilacji, pobierz paczkę deb dla twojego systemu: i386 jeśli 32 bity lub amd64 jeśli 64 bity.
Nastepnie w katalogu z pobranym debem otwórz terminal i wydaj polecenie:
sudo dpkg -i nazwa-pakietu.deb
podając pełną nazwę deba wraz z wersją.
Jeśli instalacja się nie powiedzie, wtedy:
sudo apt update
sudo apt install -f
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

terefenk

Udało się! Wrzuciłem poszukiwanie  pliku libpng12-0_1.2.50-1ubuntu2.14.04.2_i386.deb do googla, który na stronie https://packages.ubuntu.com/trusty/i386/libpng12-0/download zawiera informację o możliwości pobrania żądanego plik z podkatalogu pool/main/libp/libpng/ poprzez kliknięcie na link: security.ubuntu.com/ubuntu. W efekcie daje to możliwość pobrania i automatycznej jego instalacji poprzez instalator pakietów GDebi. Dziękuję wszystkim za cierpliwość i pomoc. Pozdrawiam!

Zobacz najnowsze wiadomości na forum