Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

BridgeLinux aktualizacja

Zaczęty przez urbek, Marzec 13, 2013, 12:30:38 PM

Poprzedni wątek - Następny wątek

urbek

Witam i jak w temacie problem jest z aktualizacją bridge linux szczegóły: http://wklej.to/fB8Ha" class="bbcode_url">http://wklej.to/fB8Ha bridge mam już chyba z miesiąc i wcześniej było wszystko oki. Kilka dni temu pojawił się pierwszy problem podczas aktualizacji, który był związany z podpisem pgp, ale dzięki pomocy naszej ircowej społeczności udało się rozwiązać. Teraz postanowiłem napisać, na forum, gdyż ktoś może mieć podobne kłopoty i wykorzysta to dla swoich celów. Jeśli ma ktoś jakies pomysły jak rozwiązac problem widoczny w powyższym linku to bedę wdzięczny.

sir_lucjan

#1
Uwaga: Metoda ryzykowna i na szybko. Lepiej zapoznać się z zaleceniami ArchWiki!!!

Wystarczy zmienić odpowiednią linijkę w /etcpacman.conf

# PGP signature checking
# NOTE: None of this will work without running `pacman-key --init` first.
# The compiled in default is equivalent to the following line. This requires
# you to locally sign and trust packager keys using `pacman-key` for them to be
# considered valid.
#SigLevel = Optional TrustedOnly
# If you wish to check signatures but avoid local sign and trust issues, use
# the following line. This will treat any key imported into pacman's keyring as
# trusted.
#SigLevel = Optional TrustAll
# For now, off by default unless you read the above.
SigLevel = Never


Ostatnia linijka tego fragmentu powinna wyglądać tak.

Wystarczy też postawić # przed

SigLevel = PackageRequired</div>

by uzyskać taką formę

#SigLevel = PackageRequired

Od teraz powinno działać dobrze.
Dell Inspiron 15-3542 (3542-2538) || Arch Linux || linux-lucjan-git

urbek

#2
@sir_lucjan dzięki, już to nie aktualne, ale na forum na pewno komuś się przyda i nie wykluczone, że sam jeszcze z tego skorzystam, bo to dopiero początek moich prób z systemami bazującymi na archu.

urbek

#3
Witam ponownie i nowy problem w tym samym temacie:) Otóż znowu jest problem z aktualizacją bridge i wynik moich prób aktualizacji podaję tu: http://wklej.to/zcRAV

Dowiedziałem, się, że coś w archu zmienili i rozwiązanie mojego problemu może być tu:https://www.archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/ , ale nie za bardzo mogę to zrozumieć i będę wdzięczny jak ktoś poświęci mi trochę czasu i spróbuje mi pomóc w zrozumieniu, a w konsekwencji rozwiązaniu problemu. Poświęciłęm temu systemowi już sporo czasu i szkoda było by mi go teraz wyrzucać, bo nie chce się aktualizować, a działa bardzo dobrze.

pavroo

#4
Witaj

Według opisu należy:

1. Przenieść wszystkie nieoficjalne pliki binarne z katalogów /bin, /sbin lub /usr/sbin do /usr/bin

Listę takich plików można wygenerować poleceniem:

Code:

pacman -Qqo /bin /sbin /usr/sbin | pacman -Qm -


2. Sprawdź również pakiety zainstalowane z nieoficjalnych repozytoriów:

Code:

paclist <repo> | awk ' { print $1 } ' | pacman -Ql - | grep ' /s\?bin/\| /usr/sbin/'


3. Upewnij się, że jakiekolwiek pakiety z IgnorePkg lub IgnoreGroup nie posiadają swoich plików binarnych w katalogach /bin, /sbin lub /usr/sbin

4. Upewnij się, że wszystkie partycje są zamontowane za pomocą autofs.

5. Zaktualizuj system:

Code:

pacman -Syu --ignore filesystem,bash
pacman -S bash
pacman -Su




Koniec przekazu :)
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

urbek

#5
Pierwsze polecenie weszło i zastanawiam się gdzie szukać owej listy, którą to polecenie miało wygenerować, bo po zatwierdzeniu polecenia w konsoli mi nic nie zwróciło tylko oddało $.

Drugie polecenie daje taki wynik:

[urbek@urb-pc ~]$ paclist <repo> | awk ' { print $1 } ' | pacman -Ql - | grep ' /s\?bin/\| /usr/sbin/'

bash: błąd składni przy nieoczekiwanym znaczniku `|'

Robiłem to samo z 2 różnych źrodeł metodą kopiuj-wklej i ten sam efekt.

I jeszcze jedna sprawa: jak już będę wiedzieć które pliki są do przeniesienia to czy skopiować i zostawić kopie w wyjściowych katalogach, czy też przenieść je nie zostawiając śladu w katalogach, w których znajdowały się przed tą operacją?

pavroo

#6
Jeśli nie wykazało żadnych plików, to chyba nie masz zainstalowanych pakietów z nieoficjalnych źródeł.

Jeśli znajdziesz jakieś, to trzeba je przenieść, nie kopiować. Nie mogę tego sam sprawdzić - nie mam zainstalowanego Archa.
Czasami lepiej trzymać usta zamknięte i być traktowany jak idiota, niż je otworzyć i rozwiać wszelkie wątpliwości. Mark Twain

urbek

#7
Wszystko poszło więc problem rozwiązany:) Dzięki za pomoc pavroo,

Zobacz najnowsze wiadomości na forum