Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

Błędy w aktualizacji

Zaczęty przez Grzegorz, Maj 13, 2017, 08:32:04 AM

Poprzedni wątek - Następny wątek

Grzegorz

Witam
    Linux grzegorz-pc 4.11.0-1-MANJARO #1 SMP PREEMPT Mon May 1 06:59:15 UTC 2017 x86_64 GNU/Linux
     [grzegorz@grzegorz-pc ~]$ mhwd-kernel -li
Currently running: 4.11.0-1-MANJARO (linux411)
The following kernels are installed in your system:
   * linux411


Zaznaczony problem
   [grzegorz@grzegorz-pc ~]$ sudo pacman -Syu
:: Synchronizowanie baz danych z pakietami...
core jest aktualne
extra jest aktualne
community jest aktualne
multilib jest aktualne
:: Rozpoczynanie pełnej aktualizacji systemu...
rozwiązywanie zależności...
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: gstreamer0.10-good-plugins: instalacja libsoup (2.58.1-1) zależność przerw 'libsoup-gnome'


Poproszę o pomoc.
Grzegorz

robson75

Dzisiaj ten wątek był poruszany na Forum Manjaro.pl i z tego co się orientuje został rozwiązany.
https://manjaro.pl/forum/topic/aktualizacja-systemu-problemy/#post-3947           
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Grzegorz

Przeczytałem powyższą podpowiedź , jak dla mnie czarna magia.Może mi ktoś napisać krok po kroczku jak ten problem rozwiązać , co odinstalować , co zostawić by system ruszył?
Z góry dziękuje.
Grzegorz

robson75

@Grzegorz Przecież w podanym poście jest jasno sprecyzowane że zbędnym pakietem w systemie jest "gstreamer0.10" i należy go odinstalować, jak i jego zależności.
Nie zwracałbym tez uwagi że podczas odinstalowania pakietu "gstreamer0.10" zostaniesz ostrzeżony że pakiet jest potrzebny. Śmiało można go odinstalować ponieważ wyżej wymieniony pakiet jest przestarzały i od dawna nie wspierany.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Grzegorz

Wykonałem następujące czynności z poziomu menażera aktualizacji:
zaznaczyłem do aktualizacji wszystkie pakiety oprócz
gstreamer 0.10-good plugins
libsup-gnome
xorg-serwer
to pakiety w konflikcie
aktualizacja zakończona sukcesem
ale po restarcie system nie wstaje, mam czarny ekran z komunikatem :starting version 232
/dev/sda3:recovering journal
Grzegorz

robson75

#5
@Grzegorz Przecież ja Tobie tłumaczyłem że należy odinstalować tylko pakiet gstreamer0.10.
W takiej sytuacji należy wcisnąć jednocześnie kombinacje klawiszy Ctri+Alt+F2 (tak zwane tty) i po zalogowaniu się wklep do terminala zaklęcie:
sudo pacman -S xorg-server
I po zainstalowaniu pakietu wpisz:
reboot
A jeżeli pakiet xorg-server będzie w konflikcie z pakietem gstreamer0.10 to będziesz go musiał odinstalować zaklęciem:
sudo pacman -R gstreamer0.10
Ponieważ pakiet xorg-server jest bardzo ważnym pakietem w systemie i bez niego  system nie wstanie.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Grzegorz

Nie udało się dokonać transakcji
(konfliktujące pliki)

xorg-server:/usr/lib/xorg/modules/extensions/libglx.so-znajduje się w systemi plików.

Nie zaktualizowana żadnego pakietu.
Grzegorz

robson75

#7
W takim wypadku pozostaje tylko reinstalacja.
A gdybyś mnie posłuchał od początku i odinstalował pakiet gstreamer0.10 to aktualizacja by przebiegła prawidłowo, i po restarcie system by wstał normalnie.
Ale cóż człowiek uczy się na błędach.
Chociaż ja bym spróbował jeszcze jednego sposobu:
sudo pacman -Syu
To jest polecenie do sprawdzenia czy są dostępne aktualizacje.
Jeśli będą to wtedy odinstaluj ten nieszczęsny pakiet gstreamer0.10. poleceniem podanym w wcześniejszym moim poście. I zaktualizuj system brakującymi pakietami.
Arch Linux Xfce+compiz - 64Bit Linux User #621110

Zobacz najnowsze wiadomości na forum