Witaj na Forum Linuxiarzy
Zanim zalogujesz się, by pisać na naszym forum, zapoznaj się z kilkoma zasadami savoir-vivre'u w dziale Administracja.
Wiadomości z problemami zamieszczone w wątku "Przywitaj się" oraz wszelkie reklamy na naszym forum będą usuwane.

jasność ekranu

Zaczęty przez Piejanto, Grudzień 26, 2015, 04:21:43 PM

Poprzedni wątek - Następny wątek

Piejanto

Na Ubuntu i Mint też miałem problemy ale dawało się naprawić z pomocą Linuxiarzy.pl i zawsze to były drobne uzupełnienia w pliku grub. Teraz po próbie zmiany dystrybucji, pod Ubuntu też nie działało i dlatego wróciłem do Antergosa. Spróbuję Twojej porady. Dzięki.

Piejanto

UNetbootin już na Antergosa nie działa. Pierwszy pendriwe z Antergosem (32) zrobiłem za pomoca UNetbootina W
lecie poprzedniego roku, a następny juz mi nie wyszedł. Doczytałem, że Antergos już się nie poddaje UNetbootinowi. Była porada, jak zrobić Live pod Linuxem i własnie ten pendrive  Antergos(64)Live jest wykonany wg tej porady. Próbowałem sztuki z Debianem, ale mi nie wychodzi i komp po prostu nie widzi systemu na pendrive, mimo, że po wejściu do zawartości, niby wszystko jest na swoim miejscu.

Piejanto

Co do działania gruba na antergosi, to też to brałem pod uwagę, ale porada którą przedstawiłem jako znalezioną w Sieci dotyczy raczej BIOS-ów kompowych, z preinstalowanym Windows, dlatego wziąłem to pod uwagę. Jeśli chodzi i Antergosa, to mam pulpit XFCE. Jak już mówiłem, z tego samego pendrive instalacyjnego instalowałem Antergosa w tej samej konfiguracji na netbooku i notbooku. Na netboku był niegdyś preinstalowany Linux Linpus, a na notbooku jest preinstalowany Windows7 i doinstalowany przeze mnie Linux. Najpierw to było Ubuntu, później Mint. Po pierwszej instalacji Linuxa poszło gładko, po aktualizacjach musiałem poprawiać GRUB-a. działało. Ponieważ Ubuntu zaczeło zmieniać swoje składniki tak, że nie działały wersje, na których pracowałem i na dodatek preferowało pulpit Unitu, przeszedłem na Antergosa. Mam nadzieję, że mi sie uda naprawić regulację jasności z Waszą pomocą. Na Debiana już się chyba nie zdecyduję, tym bardziej, że nie mam gwarancji, że regulacja będzie działała.

Albedo 0.64

Sprawdziłem Antergos u siebie. UNetbootin nagrał mi iso na usb ale system nie chciał się uruchomić. Powtórzyłem operację na LiLi USB Creator i tu poszło gładko. Na moim komputerze nie działa jedynie wifi, pozostałe ustawienia są ok, regulacja jasności ekranu działa normalnie. Próby przeprowadziłem na edycji Gnome. Proponuję sprawdzić inne środowiska, może Gnome lub Mate będzie działać lepiej od Xfce?
MX Linux XFCE
Linux registered user 556565

Piejanto

OK. Spróbuję, chociaż już się przyzwyczaiłem do XFCE. Dzięki za podpowiedź o LiLi USB Creator.

Maromann

co do problemu ustawienia jasności. wydaje mi się, że jest on bardziej złożony, a porady nietrafne. osobiście przerabiałem temat z kartą radeon hd6320. rozwiązanie problemu zależy od karty i wersji jądra. żeby zobrazować. w przypadku jądra 3.2 nie miałem żadnych problemów z grafiką i wifi, z jądrem 3.13 nie miałem wifi, a z 3.16 ani wifi, ani ustawienia jasności. i wszystko w ramach jednej dystrybucji (backported wheezy)
i stąd - po pierwsze, jaka jest karta graficzna?

ustawienia jasności są zapisane w katalogu /sys/class/backlight. u mnie w pliku /sys/class/backlight/acpi_video0/brightness. sprawdź jakie masz tam wartości (zamiast katalogu acpi_video0 może być inny katalog, odpowiedni do Twojej karty graficznej).

ustawienie jasności możliwe jest z terminala. u mnie komendą (jako root)
echo 3 > /sys/class/backlight/acpi_video0/brightness

po restarcie systemu wartość w pliku jest resetowana do 100, stąd każde uruchomienie wymaga ponownego ustawienia jasności - ponieważ używam debiana oldstable, to dopisałem stosowną linijkę w pliku /etc/rc.local.

ustawień parametrów jądra, jest więcej niż wskazano powyżej. u mnie akurat powyższe nie działają. spróbuj najpierw zidentyfikować kartę i pozmieniać wartości zapisane w pliku brightness. dodatkowo, w internecie jest wiele porad, ale trzeba szukać na stronach angielskich poprzez jakieś słowa kluczowe - np. nazwa dystrybucji, karta i brightness.

pozdrawiam,


Albedo 0.64

Kolega Maromann ma wiele racji niemnej jednak nie zmienia to faktu, że u mnie regulacja jasności działa prawidłowo na tej samej dystrybucji z innym środowiskiem. Przykłady z Debiana oldstable mają się nijak do Antergosa.
MX Linux XFCE
Linux registered user 556565

Piejanto

dzięki za podpowiedzi. Jeśli chodzi o Debiana, zrobiłem pendrive z Debianem Live pod Antergosem z polecenia > sudo dd bs=4M if=/home/julia/Downloads/debian-live-8.2.0-amd64-xfce-desktop.iso of=/dev/sdb && sync < zadziałało i Debian się uruchomił. Niestety, bez możliwości regulacji jasności. Znaczy... tak jak w Antergosie i Ubuntu, aplet się pokazuje i "udaje" że jest regulacja, ale w praktyce ekran świeci na full. Po uruchomieniu Windows7 regulacja działa bez zarzutu. Dodam, że poprzednio wymienione i uruchamiane dystrybucje, działają na moim netbooku bez zarzutu. Brak regulacji dotyczy tylko laptopa. Spróbuję jeszcze podłubać według porady kol. Maromanna ale wiele sobie nie obiecuję, bo w gruncie rzeczy jestem jedynie miłośnikiem Linuxa, a nie żadnym linuxiarzem. gdyby komus przyszło jeszcze cos do głowy z tą regulacją, to proszę o sugestie. Będę walczył. Pzdr.

Piejanto

Szanowni Linuxiarze. Ponieważ przez 120 dni szukałem rozwiązania regulacji jasności ekranu na moim Acerze, dotarłem wreszcie do fachowca. Sprawa okazała się dziecinnie prosta. Otóż:

Acer - jak się okazało - ma dwie karty grafiki. Podczas instalacji system klawiaturę połączył z jedną kartą, a obsługę jasności połączył z drugą kartą.  W efekcie podczas próby regulacji na ekranie pojawiały się informacje o zmianie jasności, a zmiana nie następowała. Wszystko.

Niestety, nie wiem, jaki był sposób połączenia tych dwóch funkcji na jednej, wybranej karcie grafiki, ale myślę, że to dla Linuxiarzy cenna wskazówka. Pozdrawiam wszystkich, którzy usiłowali mi w tym względzie pomóc.

Piejanto

Jasność ekranu!   Sprawa się wyjaśniła. Poszedłem do specjalisty i okazało się, że ACER ma dwie karty grafiki. System się zainstalował tak, że wizja szła z innej i na innej była zainstalowana klawiatura. Trzeba było pokazać ścieżkę klawiaturze do odpowiedniej karty graficznej i teraz wszystko gra.

Zobacz najnowsze wiadomości na forum